This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 22013 - Submodules are not built/installed
Submodules are not built/installed
Status: CLOSED NOTABUG
Product: Red Hat Powertools
Classification: Retired
Component: Gtk-Perl (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-10 02:40 EST by Chris Dunlop
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-10 02:40:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Dunlop 2000-12-10 02:40:15 EST
From the Gtk-Perl-0.7000 NOTES file:

As of public release 0.7000, the submodules in Perl/Gtk need to be built
separately as outlined in the INSTALL file. This may change in a future
point release if there is demand for compiling all the modules at once.

The Perl/Gtk submodules are not built/installed.

From the Gtk-Perl-0.7000 NOTES file:

As of public release 0.7000, the submodules in Perl/Gtk need to be built
separately as outlined in the INSTALL file. This may change in a future
point release if there is demand for compiling all the modules at once.
Comment 1 Tim Powers 2000-12-10 08:56:39 EST
OK. I saw that in the INSTALL file too, so was under the impression that nobody
used that stuff normally. Since you said something, I'm putting it back in for
the next release. The Gtk-Perl-0.7004-3 package should show up in rawhide the
next time rawhide gets updated. Until then, you can get the packages from here
if you want them:

  http://people.redhat.com/timp/SRPMS

and

  http://people.redhat.com/timp/RPMS

I'm resolving this as "not a bug" since it's actually an RFE on something we
decided not to include based on the language of the INSTALL file, BUT, the we
will add these modules for the upcoming release since you need them.

Tim
Comment 2 Chris Dunlop 2000-12-10 20:46:46 EST
OK, great.  Your changes are almost exactly like the ones I made myself.  Great
minds and all...

I was looking into splitting the submodules into subpackages of the main
Gtk-Perl package, but don't have time to do it just now.

You may be interested in some further changes to the spec file I made:

  ftp://ftp.onthe.net.au/private/Gtk-Perl.spec.diff

Note You need to log in before you can comment on or make changes to this bug.