This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 220131 - azureus fails to start with java.lang.NoClassDefFoundError: org/bouncycastle/jce/spec/ECParameterSpec
azureus fails to start with java.lang.NoClassDefFoundError: org/bouncycastle/...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 20:24 EST by Julian C. Dunn
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 13:35:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian C. Dunn 2006-12-18 20:24:58 EST
Description of problem:

azureus no longer starts since the latest update to bouncycasle.

Version-Release number of selected component (if applicable):

azureus-2.5.0.0-9.fc6

How reproducible:

Always

Steps to Reproduce:
1. Try to start azureus.
2.
3.
  
Actual results:

jupiter:/net/fs/usr/home/staff/jdunn$ azureus
changeLocale: *Default Language* != English (United States). Searching without
country..
changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (United States)'
(en_US), using 'English (default)'
Exception in thread "main" java.lang.NoClassDefFoundError:
org/bouncycastle/jce/spec/ECParameterSpec
        at
com.aelitis.azureus.core.security.impl.CryptoManagerImpl.<init>(CryptoManagerImpl.java:75)
        at
com.aelitis.azureus.core.security.impl.CryptoManagerImpl.getSingleton(CryptoManagerImpl.java:60)
        at
com.aelitis.azureus.core.security.CryptoManagerFactory.getSingleton(CryptoManagerFactory.java:33)
        at
com.aelitis.azureus.core.impl.AzureusCoreImpl.<init>(AzureusCoreImpl.java:155)
        at
com.aelitis.azureus.core.impl.AzureusCoreImpl.create(AzureusCoreImpl.java:92)
        at
com.aelitis.azureus.core.AzureusCoreFactory.create(AzureusCoreFactory.java:46)
        at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:143)
        at org.gudy.azureus2.ui.swt.Main.main(Main.java:162)

Expected results:

azureus to start correctly.

Additional info:

I wonder if this is related to the recent bouncycastle release. I have

bouncycastle-1.34-2.fc6

of December 11th.

Someone else is also reporting this bug in a comment #12 to bug 212811 but I
thought it deserved a bug report of its own.
Comment 1 Nicholas Miell 2006-12-18 22:55:32 EST
bouncycastle was upgraded, the Azureus startup script should probably use the
unversioned "/usr/share/java/bcprov.jar" instead of a versioned jar.
Comment 2 Julian C. Dunn 2006-12-18 23:08:27 EST
Yep that seems to be the problem... would it be possible to just make the
startup script use 'build-classpath bcprov' ?
Comment 3 Nicholas Miell 2006-12-18 23:34:19 EST
Hmm. It appears build-classpath will work now (the last time this happened --
bug 212149 -- it didn't due to a lack of a bcprov.jar symlink, iirc.).
Comment 4 Jan-Thomas Czornack 2006-12-19 06:07:10 EST
I updated to bouncycastle.i386 1.34-2.fc6 on the 14th december and was using
Azureus until this morning. The problem appeared after ther last update (from
yum.log):

Dec 19 09:18:02 Updated: faac.i386 1.25-2.lvn6
Dec 19 09:19:21 Installed: kernel.i686 2.6.18-1.2868.fc6
Dec 19 09:19:29 Updated: perl-PDL.i386 2.4.2-6.fc6
Dec 19 09:20:09 Installed: kernel-devel.i686 2.6.18-1.2868.fc6
Dec 19 09:20:13 Updated: kernel-headers.i386 2.6.18-1.2868.fc6
Dec 19 09:20:14 Installed: kmod-nvidia.i686 1.0.9631-1.2.6.18_1.2868.fc6

I don't think I have changed something else on my system.
Comment 5 Jan-Thomas Czornack 2006-12-19 06:14:05 EST
(In reply to comment #4)

Oops. Please disregard my last message. The problem was, that I accidentially
set the $PATH variable to a different bin directory (one with suns jdk1.5.0_10
installed)
Comment 6 Anthony Green 2006-12-19 13:35:34 EST
This is fixed in azureus-2_5_0_0-11, which should get pushed out within a day or
so (for FC-6 and rawhide). 

Note You need to log in before you can comment on or make changes to this bug.