Bug 220133 - yum cannot detect/list new packages added to a local repository
yum cannot detect/list new packages added to a local repository
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 20:30 EST by Satish Balay
Modified: 2014-01-21 17:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 10:43:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2006-12-18 20:30:31 EST
Description of problem:

One of the repositories I use is a local repo - where I keep rpms that I build
locally. Once the rpm is built - I update the repodata with 'createrepo .'.
However - yum is inable to find this newly built rpm when 'yum list foobar' is
invoked


Version-Release number of selected component (if applicable):
yum-3.0.1-2.fc6

How reproducible:
always


Steps to Reproduce:
1. Create a local repo - for ex: /etc/yum.repos.d/local.repo with the content
[local]
baseurl=file:///path/rpm
enabled=1
gpgcheck=0

2. add one or more rpms to /path/rpm and use it atleast once [i.e 'createrepo .'
and 'yum update]

3. Now add one more new rpm to this location [say xv...rpm]

4. Update the repodata with 'createrepo .'

5. Now try 'yum list xv' or 'yum install xv'

  
Actual results:

[root@asterix ~]# yum list xv
Loading "installonlyn" plugin
Loading "changelog" plugin
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished


Expected results:

Proper listing of the presence of xv


Additional info:

'yum clean all; yum list xv' works arround this problem.

[root@asterix ~]# yum clean all
Loading "installonlyn" plugin
Loading "changelog" plugin
Cleaning up Everything
[root@asterix ~]# yum list xv
Loading "installonlyn" plugin
Loading "changelog" plugin
Setting up repositories
livna                     100% |=========================| 1.1 kB    00:00     
local                     100% |=========================|  951 B    00:00     
updates                   100% |=========================| 1.2 kB    00:00     
core                      100% |=========================| 1.1 kB    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================|  99 kB    00:00     
################################################## 282/282
primary.xml.gz            100% |=========================| 5.7 kB    00:00     
################################################## 12/12
primary.xml.gz            100% |=========================| 320 kB    00:01     
################################################## 1098/1098
primary.xml.gz            100% |=========================| 824 kB    00:03     
################################################## 2242/2242
primary.xml.gz            100% |=========================| 1.6 MB    00:06     
################################################## 5016/5016
Excluding Packages in global exclude list
Finished
Available Packages
xv.i386                                  3.10a-34               local
Comment 1 Seth Vidal 2006-12-19 10:43:54 EST
This is b/c the repomd.xml is being cached until a certain timeout on the client.

Just set
 metadata_expire to 0 or a lower value (it defaults to 30 minutes)

in your yum.conf.
Comment 2 Satish Balay 2006-12-19 10:50:07 EST
Ah - adding this to /etc/yum.repo.d/local.repo works for me.. thanks.

Note You need to log in before you can comment on or make changes to this bug.