Bug 220146 - ValueError: invalid literal for int()
ValueError: invalid literal for int()
Status: CLOSED DUPLICATE of bug 221166
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 03:23 EST by Hans Ulrich Niedermann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 05:13:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans Ulrich Niedermann 2006-12-19 03:23:28 EST
Description of problem:

I have run "yum update --changelog". It fetched the updated package information,
then failed with

    ValueError: invalid literal for int(): Dave Jones <davej@redhat.com>

Version-Release number of selected component (if applicable):

   yum-changelog-1.0.1-1.fc6

How reproducible:

   Probably every time someone runs

Steps to Reproduce:
1. yum update --changelog
  
Actual results:

<OUTPUT>
Changes in packages about to be updated:

kernel - 2.6.18-1.2768.fc6.i686, kernel-PAE - 2.6.18-1.2768.fc6.i686,
kernel-devel - 2.6.18-1.2768.fc6.i686, kernel-PAE-devel -
2.6.18-1.2768.fc6.i686, kernel-PAE-devel - 2.6.18-1.2868.fc6.i686, kernel -
2.6.18-1.2868.fc6.i686, kernel-devel - 2.6.18-1.2868.fc6.i686, kernel-doc -
2.6.18-1.2868.fc6.noarch, kernel-headers - 2.6.18-1.2868.fc6.i386, kernel-PAE -
2.6.18-1.2868.fc6.i686
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 143, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 442, in
buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/changelog.py", line 99, in postresolve_hook
    show_changes(conduit, 'Changes in packages about to be updated:')
  File "/usr/lib/yum-plugins/changelog.py", line 61, in show_changes
    for line in changelog_delta(srpms[name][0], origpkgs[name]):
  File "/usr/lib/yum-plugins/changelog.py", line 34, in changelog_delta
    if int(date) > olddate:
ValueError: invalid literal for int(): Dave Jones <davej@redhat.com>
</OUTPUT>

Expected results:

   I expected getting shown the changelogs.

Additional info:
Comment 1 Hans Ulrich Niedermann 2007-01-04 13:34:50 EST
The same issue has just occured again (yum-changelog-1.0.1-1.fc6):

openmotif - 2.3.0-0.1.9.3.i386
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 143, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 442, in
buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/changelog.py", line 99, in postresolve_hook
    show_changes(conduit, 'Changes in packages about to be updated:')
  File "/usr/lib/yum-plugins/changelog.py", line 61, in show_changes
    for line in changelog_delta(srpms[name][0], origpkgs[name]):
  File "/usr/lib/yum-plugins/changelog.py", line 34, in changelog_delta
    if int(date) > olddate:
ValueError: invalid literal for int(): Thomas Woerner <twoerner@redhat.com>
2.3.0-0.1.9.3
Comment 2 Johan Kok 2007-02-05 05:13:54 EST

*** This bug has been marked as a duplicate of 221166 ***

Note You need to log in before you can comment on or make changes to this bug.