Bug 220158 - Strange "Windowed"-param behaviour
Strange "Windowed"-param behaviour
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: glest (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 07:49 EST by Peter Lemenkov
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0.0-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-20 07:14:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Lemenkov 2006-12-19 07:49:00 EST
Description of problem:

If i change this parameter from Windowed=0 (default) to Windowed=1 (I prefer
that mode) nothing happends - the game still starts in fullscreen mode. After a
brief look I found that then game starts after this change its startup script (
glest.sh ) adds another Windowed=0 almost at the top of glest.ini

Additional info:

See the resulting glest.ini:
[petro@host-12-124 Desktop]$ cat glest.ini.after 
; === Properties File === 
; This is an example glest.ini file modified for the linux version

AiLog=0
AiRedir=0
CameraFps=100
>>>> Windowed=0 <<<<
CheckGlCaps=1
ColorBits=32
ConsoleMaxLines=10
ConsoleTimeout=1
DayTime=1000
DebugMode=0
DepthBits=16
FactoryGraphics=OpenGL
FactorySound=OpenAL
FastSpeedLoops=2
Filter=Bilinear
FilterMaxAnisotropy=1
FirstTime=0
FocusArrows=1
FogOfWar=1
FogOfWarSmoothing=1
FogOfWarSmoothingFrameSkip=3
FontConsole=-*-utopia-*-*-*-*-12-*-*-*-*-*-*-*
FontDisplay=-*-utopia-*-*-*-*-12-*-*-*-*-*-*-*
FontMenu=-*-utopia-*-*-*-*-12-*-*-*-*-*-*-*
Lang=english.lng
MaxLights=1
PathFindNodesMax=250
PathFindRefresh=10
PhotoMode=0
RefreshFrequency=75
ScreenHeight=1024
ScreenWidth=1280
ShadowAlpha=0.1
ShadowFrameSkip=2
ShadowTextureSize=256
Shadows=Disabled
SoundStaticBuffers=16
SoundStreamingBuffers=4
SoundVolumeAmbient=80
SoundVolumeFx=80
SoundVolumeMusic=90
StencilBits=0
Textures3D=1
UpdateFps=40
Windowed=1

If I remove the lower Windowed=1 and change the upper Windowed=0 to Windowed=1
everything ok.
Comment 1 Peter Lemenkov 2006-12-19 07:56:18 EST
Oops!
Looks like glest.sh doesn't responsible for that )
Comment 2 Peter Lemenkov 2006-12-19 08:07:19 EST
Another oops! Loosk like glest.sh does responsible for that behaviour. :)

After glest.ini is created thete is a line ChangeDisplay=1 in glest.ini which
changes after the next start by simple sed expression to Windowed=0 
Comment 3 Aurelien Bompard 2006-12-20 07:14:43 EST
Fixed in release 5, thanks !

Note You need to log in before you can comment on or make changes to this bug.