Bug 220160 - LM Sensors doesn't work on ABit AB9 Pro
LM Sensors doesn't work on ABit AB9 Pro
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 08:19 EST by Joshua Rosen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-01 16:57:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Rosen 2006-12-19 08:19:41 EST
Description of problem:
LM Sensors doesn't work on ABit AB9 Pro

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Install LM Sensors RPM on system
2. run sensors-detect
3. enable the sensors,
/etc/modprobe.conf:

#----cut here----
# I2C module options
alias char-major-89 i2c-dev
#----cut here----

To load everything that is needed, add this to some /etc/rc* file:

#----cut here----
# I2C adapter drivers
modprobe i2c-i801
modprobe i2c-isa
# I2C chip drivers
modprobe eeprom
modprobe w83627ehf
# sleep 2 # optional
/usr/bin/sensors -s
  
Actual results: Getting no readings,

sensors
w83627ehf-isa-0290
Adapter: ISA adapter
Case Fan:    0 RPM  (min =    0 RPM, div = 128)
CPU Fan:     0 RPM  (min =    0 RPM, div = 128)
fan3:        0 RPM  (min =    0 RPM, div = 128)
fan4:        0 RPM  (min =    0 RPM, div = 128)
Sys Temp:     -1°C  (high =    -1°C, hyst =    -1°C)  
CPU Temp:   +0.0°C  (high =  +0.0°C, hyst =  +0.0°C)  
temp3:      +0.0°C  (high =  +0.0°C, hyst =  +0.0°C)  

Expected results:


Additional info:
lspci
00:00.0 Host bridge: Intel Corporation 82P965/G965 Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82P965/G965 PCI Express Root Port (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1
(rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3
(rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5
(rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HB/HR (ICH8/R) LPC Interface
Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA IDE
Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801H (ICH8 Family) 2 port SATA IDE
Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 7300 LE (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
Express Gigabit Ethernet controller (rev 01)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
Express Gigabit Ethernet controller (rev 01)
05:00.0 IDE interface: JMicron Technologies, Inc. JMicron 20360/20363 AHCI
Controller (rev 02)
05:00.1 IDE interface: JMicron Technologies, Inc. JMicron 20360/20363 AHCI
Controller (rev 02)
06:02.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000
Controller (PHY/Link)
Comment 1 Hans de Goede 2007-07-01 16:57:31 EDT
Hi,

Short introduction, I'm a Fedora contributer and since I'm involved in
lm_sensors upstream, I've also become a co-maintainer of lm_sensors in Fedora. I
also happen to be the author of the driver for the Abit uGuru hardware
monitoring chip.

And that hardware monitoring chip is the one your motherboard is using, it may
also have an w83627ehf superio chip, but as your current sensors output tells
you, the sensors of this superio chip are not connected.

Actually I'm the author of 2 drivers for the Abit uGuru hardware monitoring
chip. The first driver I wrote works for revision 1 and 2 of this chip, with the
3th version Abit has changed the "protocol" on the ISA bus to talk to the chip,
so that version requires a different driver.

This driver has just passed review and should show up in the -mm kernels soon,
to find its way into the mainline from there.

In the mean time you can download this driver here:
http://people.atrpms.net/~hdegoede/abituguru3-0.1.5.tar.gz

Installations instructions:
yum install kernel-devel
"untar"
cd abituguru3-0.1.5
make
modprobe hwmon
insmod abituguru3.ko

Now type dmesg, you should see something like:
abituguru3: found Abit uGuru3, motherboard ID: XXXX (unknown)

I would like you to report back here with what XXXX is for your motherboard, so
that I can change the (unknown) into (Abit AB9 Pro)

Know you can read your sensors by catting the files under:
/sys/bus/platform/devices/abituguru3.224/

For example to read your CPU voltage in milivolts do:
cat /sys/bus/platform/devices/abituguru3.224/in0_input

If you want to know which input is what, cat the labels:
cat /sys/bus/platform/devices/abituguru3.224/in0_label


Unfortunately "sensors" will not work as just having a driver with support is
not enough, due to some legacy, libsensors needs to know about the chip too.
This will change with libsensors-3.0, which will dynamicly detect the available
chips instead of only recognizing chips it knows about.

Depending on the speed of libsensors3's progress I might write a patch to add
support for the abituguru3 to libsensors-2.10.x . Would you be willing to test
such a patch? (I don't have an abituguru3 motherboard).

In the mean time you can get a working sensors command by manually installing
lm_sensors from svn, notice that this version is not compatible with the 2.10.x
version and thus things like ksensors will not work. To install the svn version do:
yum remove lm_sensors
svn checkout http://lm-sensors.org/svn/lm-sensors/branches/lm-sensors-3.0.0
cd lm-sensors-3.0.0
make
sudo make install
echo /usr/local/lib > local.conf
sudo mv local.conf /etc/ld.so.conf.d
sudo ldconfig

Notice that the current svn sensors command will not use the inX_label files, I
need to fix that, again help with testing would be appreciated.
Comment 2 Hans de Goede 2007-07-02 03:49:01 EDT
Hi,

Next time please reply through bugzilla, thats easier for tracking this then a
lot of mails, thanks!

B. Joshua Rosen wrote:
> I've downloaded the new driver however I don't seem to be able to
> install it. I'm currently running Scientific Linux 5 (RHEL 5) on my AB9
> Pro system. I'm using a 2.6.21.5 kernel. I don't seem to have hwmon on
> the system although I think I built it,
> 
> modprobe hwmon
> FATAL: Module hwmon not found.
> 
> 
> insmod abituguru3.ko 
> insmod: error inserting 'abituguru3.ko': -1 No such device
> 
> 
> Should I download and build a different kernel?
> 
> 
> Here is the hardware monitoring section from my .config file,
> 
> #
> # Hardware Monitoring support
> #
> CONFIG_HWMON=y

Okay, the 'modprobe hwmon' error is ont a problem, as you have hwmon compil;ed
hard into your kernel, as can be seen above. 

This however:

> insmod abituguru3.ko 
> insmod: error inserting 'abituguru3.ko': -1 No such device

Is a problem, can you attach the output of 'dmesg|grep abituguru' ? For some
reason its not finding the uguru3 .

Also can you try using 'insmod abituguru3.ko force=1' ?
And again attach the output of 'dmesg|grep abituguru', if that insmod commmands
does work you can also try reading the sensors as described above.

Thanks!
Comment 3 Joshua Rosen 2007-07-02 08:34:59 EDT
abituguru3: no Abit uGuru3 found, data = 0x08, cmd = 0xAC
abituguru3: no Abit uGuru3 found, data = 0x08, cmd = 0xAC
abituguru3: no Abit uGuru3 found, data = 0x08, cmd = 0xAC
abituguru3: no Abit uGuru3 found, data = 0x08, cmd = 0xAC
abituguru3: Assuming Abit uGuru3 is present because of "force" parameter
abituguru3: found Abit uGuru3, motherboard ID: 0014 (unknown)

/home/bjrosen/tmp/abituguru3-0.1.5> cat
/sys/bus/platform/devices/abituguru3.224/temp1_input
39000
/home/bjrosen/tmp/abituguru3-0.1.5> cat
/sys/bus/platform/devices/abituguru3.224/temp2_input
34000
/home/bjrosen/tmp/abituguru3-0.1.5> cat
/sys/bus/platform/devices/abituguru3.224/temp3_input
42000

cat /sys/bus/platform/devices/abituguru3.224/in0_input 
1190
Comment 4 Hans de Goede 2007-07-02 11:13:39 EDT
Looks good, I'll teach the driver to recognize an abituguru3, with the given
data and cmd values. And I'll add the Abit AB9 Pro to the list as ID 0014, so
that it will no longer be unknown.
Comment 5 Hans de Goede 2007-07-02 16:52:39 EDT
Here is a new version:
http://people.atrpms.net/~hdegoede/abituguru3-0.1.6.tar.gz

This version should not use force=1 when installing and also should identify
your motherboard as AB9 Pro instead of as unknown.

Can you test this please?
Comment 6 Joshua Rosen 2007-07-02 19:30:28 EDT
I rebuilt the 2.6.21.5 kernel without the abituguru module and made hwmon a
module. I then built and installed 3-0.1.6


dmesg | grep abit
r8169 Gigabit Ethernet driver 2.2LK-NAPI loaded
r8169 Gigabit Ethernet driver 2.2LK-NAPI loaded
abituguru3: Unknown symbol hwmon_device_register
abituguru3: Unknown symbol hwmon_device_unregister
abituguru3: found Abit uGuru3, motherboard ID: 0014 (Abit AB9 Pro)
Comment 7 Joshua Rosen 2007-07-02 19:43:12 EDT
I just tried to install lm-sensors 3.0.0. It is looking for a module called
coretemp which I don't have installed. Is this a new module? I don't see a
coretemp in the .config file for 2.6.21.5

Comment 8 Joshua Rosen 2007-07-03 00:17:22 EDT
I built a 2.6.22.rc7 kernel and then installed 3-0.1.6 and lm-sensors-3.0.0.

The CPU temperature is still not being read,

sensors3
abituguru3-isa-00e0
Adapter: ISA adapter
in0:            +1.15 V  (min =  +0.00 V, max =  +1.60 V)
in1:            +1.97 V  (min =  +1.60 V, max =  +2.40 V)
in2:            +0.98 V  (min =  +0.80 V, max =  +1.20 V)
in3:            +1.22 V  (min =  +0.95 V, max =  +1.45 V)
in4:            +1.25 V  (min =  +1.00 V, max =  +1.50 V)
in5:            +2.98 V  (min =  +2.40 V, max =  +3.60 V)
in6:            +1.03 V  (min =  +0.85 V, max =  +1.25 V)
in7:           +12.12 V  (min =  +9.60 V, max = +14.40 V)
in8:           +12.06 V  (min =  +9.60 V, max = +14.40 V)
in9:            +5.13 V  (min =  +3.99 V, max =  +6.00 V)
in10:           +3.28 V  (min =  +2.64 V, max =  +3.94 V)
in11:           +5.10 V  (min =  +3.99 V, max =  +6.00 V)
fan1:          1440 RPM  (min =  300 RPM)
fan2:             0 RPM  (min =  300 RPM)
fan3:             0 RPM  (min =  300 RPM)
temp1:          +39.0°C  (high = +75.0°C, crit = +85.0°C)  
temp2:          +33.0°C  (high = +55.0°C, crit = +65.0°C)  
temp3:          +42.0°C  (high = +80.0°C, crit = +90.0°C)  

w83627ehf-isa-0290
Adapter: ISA adapter
VCore:          +2.04 V  (min =  +2.04 V, max =  +2.04 V)   ALARM
in1:           +13.46 V  (min = +13.46 V, max = +13.46 V)   ALARM
AVCC:           +4.08 V  (min =  +4.08 V, max =  +4.08 V)   ALARM
3VCC:           +4.08 V  (min =  +4.08 V, max =  +4.08 V)   ALARM
in4:            +2.04 V  (min =  +2.04 V, max =  +2.04 V)   ALARM
in5:            +2.04 V  (min =  +2.04 V, max =  +2.04 V)   ALARM
in6:            +6.53 V  (min =  +6.53 V, max =  +6.53 V)   ALARM
VSB:            +4.08 V  (min =  +4.08 V, max =  +4.08 V)   ALARM
VBAT:           +4.08 V  (min =  +4.08 V, max =  +4.08 V)   ALARM
in9:            +2.04 V  (min =  +2.04 V, max =  +2.04 V)   ALARM
Case Fan:         0 RPM  (min =    0 RPM, div = 128) ALARM
CPU Fan:          0 RPM  (min =    0 RPM, div = 128) ALARM
Aux Fan:          0 RPM  (min =    0 RPM, div = 128) ALARM
fan4:             0 RPM  (min =    0 RPM, div = 128) ALARM
Sys Temp:        -1.0°C  (high =  -1.0°C, hyst =  -1.0°C)   ALARM
CPU Temp:        +0.0°C  (high =  +0.0°C, hyst =  +0.0°C)   ALARM
AUX Temp:        +0.0°C  (high =  +0.0°C, hyst =  +0.0°C)   ALARM

coretemp-isa-0000
Adapter: ISA adapter
temp1:            +43.0°C
temp1_crit:       +85.0°C

coretemp-isa-0001
Adapter: ISA adapter
temp1:            +46.0°C
temp1_crit:       +85.0°C
Comment 9 Hans de Goede 2007-07-03 03:44:40 EDT
The CPU temp is being read, three times actually. I assume with it not being
read you mean the w83627ehf CPU-temp reading, that is indeed invalid, as the
sensors of this chip aren;t hooked up, just rmmod it, you do not need it with an
uguru motherboard.

temp1 in the abituguru driver output is the cpu temp (as seen on the
motherboard) and the 2 coretemp temperatures, are the temperatures of the 2
cores of your processors as seen by temperature sensors inside the processor.

Thanks for trying lm-sensors 3.0 I'll write a patch for 3.0 to make it report
the proper labels for the uguru driver and post that here for testing. This is
as time permits, so this might take a while.
Comment 10 Joshua Rosen 2007-07-03 07:52:12 EDT
Thanks. Let me know when you have the lm-sensors patch and I'll give it a try.
Comment 11 Hans de Goede 2007-07-04 03:55:36 EDT
The patch is now in svn, do:
cd lm-sensors-3.0.0
svn update
make
sudo make install
sensors3

And then you should see labels for the abituguru entries
Comment 12 Joshua Rosen 2007-07-04 07:46:10 EDT
Here are the results. I notice that the CPU temperature is lower then either of
the coretemps. Is the CPU temperature sensor an external sensor?

Also there is an extraneous character in the temp readings, Â, you should clean
that up.


abituguru3-isa-00e0
Adapter: ISA adapter
CPU Core:          +1.14 V  (min =  +0.00 V, max =  +1.60 V)
DDR:               +1.97 V  (min =  +1.60 V, max =  +2.40 V)
DDR VTT:           +0.98 V  (min =  +0.80 V, max =  +1.20 V)
CPU VTT 1.2V:      +1.22 V  (min =  +0.95 V, max =  +1.45 V)
MCH & PCIE 1.5V:   +1.25 V  (min =  +1.00 V, max =  +1.50 V)
MCH 2.5V:          +2.98 V  (min =  +2.40 V, max =  +3.60 V)
ICH 1.05V:         +1.03 V  (min =  +0.85 V, max =  +1.25 V)
ATX +12V (24-Pin):+12.18 V  (min =  +9.60 V, max = +14.40 V)
ATX +12V (4-pin): +12.12 V  (min =  +9.60 V, max = +14.40 V)
ATX +5V:           +5.13 V  (min =  +3.99 V, max =  +6.00 V)
+3.3V:             +3.28 V  (min =  +2.64 V, max =  +3.94 V)
5VSB:              +5.10 V  (min =  +3.99 V, max =  +6.00 V)
CPU Fan:          1500 RPM  (min =  300 RPM)
NB Fan:              0 RPM  (min =  300 RPM)
SYS Fan:             0 RPM  (min =  300 RPM)
CPU:               +39.0°C  (high = +75.0°C, crit = +85.0°C)  
System :           +34.0°C  (high = +55.0°C, crit = +65.0°C)  
PWM:               +42.0°C  (high = +80.0°C, crit = +90.0°C)  

w83627ehf-isa-0290
Adapter: ISA adapter
VCore:          +2.04 V  (min =  +2.04 V, max =  +2.04 V)   ALARM
in1:           +13.46 V  (min = +13.46 V, max = +13.46 V)   ALARM
AVCC:           +4.08 V  (min =  +4.08 V, max =  +4.08 V)   ALARM
3VCC:           +4.08 V  (min =  +4.08 V, max =  +4.08 V)   ALARM
in4:            +2.04 V  (min =  +2.04 V, max =  +2.04 V)   ALARM
in5:            +2.04 V  (min =  +2.04 V, max =  +2.04 V)   ALARM
in6:            +6.53 V  (min =  +6.53 V, max =  +6.53 V)   ALARM
VSB:            +4.08 V  (min =  +4.08 V, max =  +4.08 V)   ALARM
VBAT:           +4.08 V  (min =  +4.08 V, max =  +4.08 V)   ALARM
in9:            +2.04 V  (min =  +2.04 V, max =  +2.04 V)   ALARM
Case Fan:         0 RPM  (min =    0 RPM, div = 128) ALARM
CPU Fan:          0 RPM  (min =    0 RPM, div = 128) ALARM
Aux Fan:          0 RPM  (min =    0 RPM, div = 128) ALARM
fan4:             0 RPM  (min =    0 RPM, div = 128) ALARM
Sys Temp:        -1.0°C  (high =  -1.0°C, hyst =  -1.0°C)   ALARM
CPU Temp:        +0.0°C  (high =  +0.0°C, hyst =  +0.0°C)   ALARM
AUX Temp:        +0.0°C  (high =  +0.0°C, hyst =  +0.0°C)   ALARM

coretemp-isa-0000
Adapter: ISA adapter
Core 0:           +41.0°C
temp1_crit:       +85.0°C

coretemp-isa-0001
Adapter: ISA adapter
Core 1:           +44.0°C
temp1_crit:       +85.0°C

Comment 13 Hans de Goede 2007-07-04 10:14:08 EDT
Thanks for testing, good to hear it works. The extra character is probably
because you don't have your terminal / LANG setting in UTF-8 mode.
Comment 14 Hans de Goede 2007-07-04 17:36:38 EDT
Hi me again,

I've finished writing libsensors 2.10.x support for the abituguru, this is
necessary as it seems that libsensors 3.0.0 will not be released anytime soon.

I would be much oblidged if you could this version a spin, I've put the SRPM (
rebuild with rpm-build --rebuild foo.srpm, will generate rpms) and a pre build
x86_64 rpm for you here:
http://people.atrpms.net/~hdegoede/lm_sensors-2.10.3-2.1.fc8.src.rpm
http://people.atrpms.net/~hdegoede/lm_sensors-2.10.3-2.1.fc8.x86_64.rpm

With this rpm installed you should also be able to use and test other libsenors
using programs like gkrellm and ksensors, after installing this rpm you can just
yum install them.

Many Thanks!
Comment 15 Joshua Rosen 2007-07-04 19:41:08 EDT
I uninstalled sensors3 and installed your RPM for 2.10.2-2.1. Here is the output

abituguru3-isa-00e0
Adapter: ISA adapter
CPU Core:               +1.13 V (min  +0.00 V, max  +1.60 V)
DDR:                    +1.97 V (min  +1.60 V, max  +2.40 V)
DDR VTT:                +0.98 V (min  +0.80 V, max  +1.20 V)
CPU VTT 1.2V:           +1.22 V (min  +0.95 V, max  +1.45 V)
MCH & PCIE 1.5V:        +1.24 V (min  +1.00 V, max  +1.50 V)
MCH 2.5V:               +2.98 V (min  +2.40 V, max  +3.60 V)
ICH 1.05V:              +1.03 V (min  +0.85 V, max  +1.25 V)
ATX +12V (24-Pin):     +12.18 V (min  +9.60 V, max +14.40 V)
ATX +12V (4-pin):      +12.12 V (min  +9.60 V, max +14.40 V)
ATX +5V:                +5.13 V (min  +3.99 V, max  +6.00 V)
+3.3V:                  +3.28 V (min  +2.64 V, max  +3.94 V)
5VSB:                   +5.10 V (min  +3.99 V, max  +6.00 V)
ERROR: Can't get IN data! (0x000d)
ERROR: Can't get IN data! (0x000e)
CPU:                      +37°C  (high =   +75°C, crit =   +85°C)  
System :                  +31°C  (high =   +55°C, crit =   +65°C)  
PWM:                      +40°C  (high =   +80°C, crit =   +90°C)  
ERROR: Can't get TEMP data! (0x0054)
ERROR: Can't get TEMP data! (0x0055)
ERROR: Can't get TEMP data! (0x0056)
ERROR: Can't get TEMP data! (0x0057)
CPU Fan:               1080 RPM (min  300 RPM)               
NB Fan:                   0 RPM (min  300 RPM)               
SYS Fan:                  0 RPM (min  300 RPM)               
ERROR: Can't get FAN data! (0x0094)
ERROR: Can't get FAN data! (0x0095)
ERROR: Can't get FAN data! (0x0096)
ERROR: Can't get FAN data! (0x0097)
ERROR: Can't get FAN data! (0x0098)

w83627ehf-isa-0290
Adapter: ISA adapter
VCore:     +2.04 V  (min =  +2.04 V, max =  +2.04 V) ALARM
in1:      +13.46 V  (min = +13.46 V, max = +13.46 V) ALARM
AVCC:      +4.08 V  (min =  +4.08 V, max =  +4.08 V) ALARM
3VCC:      +4.08 V  (min =  +4.08 V, max =  +4.08 V) ALARM
in4:       +2.04 V  (min =  +2.04 V, max =  +2.04 V) ALARM
in5:       +2.04 V  (min =  +2.04 V, max =  +2.04 V) ALARM
in6:       +6.53 V  (min =  +6.53 V, max =  +6.53 V) ALARM
VSB:       +4.08 V  (min =  +4.08 V, max =  +4.08 V) ALARM
VBAT:      +4.08 V  (min =  +4.08 V, max =  +4.08 V) ALARM
in9:       +2.04 V  (min =  +2.04 V, max =  +2.04 V) ALARM
Case Fan:    0 RPM  (min =    0 RPM, div = 128) ALARM
CPU Fan:     0 RPM  (min =    0 RPM, div = 128) ALARM
Aux Fan:     0 RPM  (min =    0 RPM, div = 128) ALARM
fan4:        0 RPM  (min =    0 RPM, div = 128) ALARM
Sys Temp:     -1°C  (high =    -1°C, hyst =    -1°C)   ALARM
CPU Temp:   +0.0°C  (high =  +0.0°C, hyst =  +0.0°C)   ALARM
AUX Temp:   +0.0°C  (high =  +0.0°C, hyst =  +0.0°C)   ALARM

coretemp-isa-0000
Adapter: ISA adapter
Core 0:      +40°C  (high =   +85°C)                     

coretemp-isa-0001
Adapter: ISA adapter
Core 1:      +42°C  (high =   +85°C)                     
Comment 16 Hans de Goede 2007-07-05 01:36:05 EDT
Thanks,

Looks good, except for those invalid ERRORS: . Here is a version that fixes those:
http://people.atrpms.net/~hdegoede/lm_sensors-2.10.3-2.2.fc8.src.rpm
http://people.atrpms.net/~hdegoede/lm_sensors-2.10.3-2.2.fc8.x86_64.rpm

I've send the changes in this latest version upstream, upstream will soon
release 2.10.4 (in about 2-3 weeks). I'll update Fedora's official package (in
rawhide) to 2.10.4 when it is released, since the driver is also heading to the
upstream kernel, that means that by F-8 this will hopefully work out of the box.
Comment 17 Joshua Rosen 2007-07-05 07:14:31 EDT
I abituguru3 going to make it into 2.6.22?
Comment 18 Hans de Goede 2007-07-05 07:16:17 EDT
Nope, I hope / think it will get merged at the start of the 2.6.23 cycle.

Note You need to log in before you can comment on or make changes to this bug.