Bug 220167 - CD Player doesn't refresh audio list when inserting new CD [NEEDINFO]
CD Player doesn't refresh audio list when inserting new CD
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-media (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 09:28 EST by Larry Troan
Modified: 2016-04-18 05:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:16:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (ltroan)


Attachments (Terms of Use)

  None (edit)
Description Larry Troan 2006-12-19 09:28:45 EST
Description of problem:
Playing music through metacity. After ejecting current CD, put a new on in but
list of songs and CD title don't refresh -- still shows former CD selection.


Version-Release number of selected component (if applicable):
RHEL5 beta2 ISO images containing metacity-2.16.0-7.el5

How reproducible:
Always

Steps to Reproduce:
1) Insert audio CD.
2) Select Applications->Sound_&_Video->CD_Player
3) Start playing CD
4) Eject current CD via "eject" button in metacity
5) Put different CD in player
6) Menu doesn't change.
7) Click PLAY and new music begins to play, bar advances, etc. but old menu
continues to display. Cycles through audio tracks but ccontinues to show old
song titles. 

Actual results:
Wrong song titles display

Expected results:
Refresh title and song selections when new CD is inserted.

Additional info:
Dell Precision 450

lspci -vv (edited)
 :
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 01)
(prog-if 8a [Master SecP PriP])
        Subsystem: Dell Unknown device 012d
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: I/O ports at <unassigned>
        Region 1: I/O ports at <unassigned>
        Region 2: I/O ports at <unassigned>
        Region 3: I/O ports at <unassigned>
        Region 4: I/O ports at ffa0 [size=16]
        Region 5: Memory at 30100000 (32-bit, non-prefetchable) [size=1K]
 :
 :
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
        Subsystem: Dell Unknown device 012d
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin B routed to IRQ 19
        Region 0: I/O ports at c800 [size=256]
        Region 1: I/O ports at cc40 [size=64]
        Region 2: Memory at ffa20400 (32-bit, non-prefetchable) [size=512]
        Region 3: Memory at ffa20000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA
PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
  :
Comment 1 Larry Troan 2006-12-19 15:16:12 EST
Internal CD player is HL-DT-ST-GCE-8481B 
Comment 2 Owen Taylor 2009-10-19 17:10:11 EDT
Metacity is the window manager; from the description this relates to gnome-cd from the gnome-media package (or, if it works with other hardware, is a kernel bug)
Comment 3 RHEL Product and Program Management 2014-03-07 07:46:59 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 RHEL Product and Program Management 2014-06-02 09:16:51 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.