Bug 220205 - Eclipse won't install on ppc64 without firefox.ppc64
Summary: Eclipse won't install on ppc64 without firefox.ppc64
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: eclipse   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
urgent
medium
Target Milestone: ---
: ---
Assignee: Ben Konrath
QA Contact: eclipse-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-19 17:40 UTC by Andrew Overholt
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-08 01:55:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Overholt 2006-12-19 17:40:07 UTC
Description of problem:


Version-Release number of selected component (if applicable):
eclipse-3.2.1-17.el5

How reproducible:
Always

Steps to Reproduce:
1. Attempt to install Eclipse on ppc64 with no firefox.ppc64
  
Actual results:
Fails due to libswt3-gtk2-3.2.1-17.el5.ppc64.rpm requiring libxpcom.so()(64bit)

Expected results:
No failure

Additional info:
We'll fix by disabling the internal browser on ppc64 and thus avoiding this
requirement.

Comment 1 Andrew Overholt 2006-12-19 21:36:12 UTC
I don't have the permissions to set devel_ack and Patrick Macdonald -- my
manager -- is on vacation.  Can someone else do it?

Comment 2 Ben Konrath 2006-12-20 16:48:44 UTC
eclipse-1:3.2.1-18.el5 has the fix for this problem. Andrew and I verified that
the ppc64 packages do not contian the swt-mozilla shared libraries and do not
require firefox ppc64.

Comment 3 Ben Konrath 2006-12-20 17:57:35 UTC
Will we need to fix this problem in Fedora as well?

Comment 4 RHEL Product and Program Management 2007-02-08 01:55:38 UTC
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.



Note You need to log in before you can comment on or make changes to this bug.