Bug 220257 - The enable/disable test option does not work properly after the first run.
The enable/disable test option does not work properly after the first run.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 17:30 EST by Chris Moore
Modified: 2008-05-01 11:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-31 16:28:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Moore 2006-12-19 17:30:34 EST
Description of problem:
The enable/disable test option does not work properly after the first run.

The user cannot change a test’s enable/disable status after the kit has run
once, no matter if that test was run or not.

Version-Release number of selected component (if applicable):
HTS 5 release 14

How reproducible:  This is an example using the virt test

  hts discovery
  hts plan
  hts print
disable Test:
  hts plan --disable --test=virt
Try and run test, when you shouldn’t be able to  (it only runs INFO, which is
correct)
  hts certify --test=virt
Enable Test:
  hts plan --enable --test=virt
run the test again to show that is truly disabled:
  hts certify --test=virt

  
Actual results:

Never enables test, nor runs the test.

Expected results:

It should enable the test.

Additional info:

The testkit seems to be grabbing the enable/disable parameter from the
/var/hts/results.xml file, instead of from the /var/hts/config.xml file.  The
config.xml displays what it is supposed to run, while the results.xml file
displays what was previously run.    

The “disabled=’true’” entry in the results.xml must be deleted for the test to
be enabled.
Comment 1 Greg Nichols 2007-01-09 15:43:11 EST
Fixed R16.
Comment 2 Greg Nichols 2007-01-23 11:18:07 EST
Please verify this fix.
Comment 3 Chris Moore 2007-01-31 17:14:53 EST
Fixed.

Note You need to log in before you can comment on or make changes to this bug.