This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 220274 - FindClass JNI failure crashes JVM
FindClass JNI failure crashes JVM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgtk-java (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stepan Kasal
:
Depends On:
Blocks: 212811
  Show dependency treegraph
 
Reported: 2006-12-19 20:54 EST by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 09:25:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for more info (1.54 KB, patch)
2006-12-19 20:54 EST, Anthony Green
no flags Details | Diff

  None (edit)
Description Anthony Green 2006-12-19 20:54:05 EST
Description of problem:
org_gnu_glib_GObject.c uses FindClass to get GObject.  When I run azureus with
the Sun JVM, this FindClass call returns null.  I'll attach a messy patch to
this bugzilla that shows how it is failing and throws an exception.
I haven't reproduced this with gcj because when I run azureus with the same
code we don't execute the code path that has us FindClass.  See Bug 212811
for more info.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Anthony Green 2006-12-19 20:54:05 EST
Created attachment 144071 [details]
Patch for more info
Comment 2 Stepan Kasal 2007-11-06 09:25:45 EST
This seems to be fixed in Fedora 8, azureus runs.

Note You need to log in before you can comment on or make changes to this bug.