Bug 220314 - [ta_IN] [fonts-tamil] - fontforge is crashing while modifying tamil font file
[ta_IN] [fonts-tamil] - fontforge is crashing while modifying tamil font file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fontforge (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-20 06:50 EST by Parag Nemade
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 08:53:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2006-12-20 06:50:06 EST
Description of problem:
While working on lohit_ta.ttf file i am getting Segmentation fault. If i tried
to move any point in any Glyph and likewise continue to modify .ttf file,
fontforge will crash

Version-Release number of selected component (if applicable):
fontforge-20061025-2.fc6
any fonts-tamil rpm

How reproducible:
always

Steps to Reproduce:
1)Install fonts-tamil rpm from FC6
2) Open font file from console as 
  fontforge lohit_ta.ttf
3) work for some time like modifying Glyph points
4)It will get crashed after some time

Actual results:
Not allowing to modify more than 2 Glyphs or not allowing to modify font file

Expected results:
It should allow to modify lohit_ta.ttf file. 


Additional info:
Comment 1 Roozbeh Pournader 2006-12-20 07:20:57 EST
I cannot reproduce this it seems.

Please install the fontforge-debuginfo package, then run fontforge using:
  gdb --args fontforge lohit_ta.ttf

at the (gdb) prompt, enter "r" and then continue working on the font. When it
crashed, copy the error messages on the terminal to this bug.
Comment 2 Parag Nemade 2006-12-21 00:42:13 EST
Quick update before seeing at comment #1
Sorry for wrong information as i just checked this bug against fonts-tamil package.

Rewording Bug as
Description of problem:
While working on lohit_ta.ttf file i am getting Segmentation fault. If i tried
to move any point in any Glyph and likewise continue to modify .ttf file,
fontforge will crash

Version-Release number of selected component (if applicable):
fontforge-20061025-2.fc6
any fonts-tamil/fonts-kannada rpm

How reproducible:
always

Steps to Reproduce:
1)Install fonts-tamil rpm from FC6
2) Open font file from console as 
  fontforge lohit_ta.ttf
3) press alt+w / click by mouse on Window Menu option 
4)It will crash with segmentation fault

Actual results:
crashing on alt+w key press on FC6

Expected results:
Should not crash with mouse click Windows Menu bar/ key press alt+w
Comment 3 Roozbeh Pournader 2006-12-21 08:07:37 EST
I still cannot make fontforge crash. Please do as instructed in comment #1 and
attach a report.
Comment 4 Kevin Fenzi 2006-12-21 15:24:59 EST
It's worth noting that there is a new version out (since yesterday) with a bunch
of fixes in it. 
Roozbeh: Perhaps we could upgrade to that and see if the problem persists?
Comment 5 Parag Nemade 2006-12-21 23:03:45 EST
gdb --args fontforge lohit_ta.ttf
GNU gdb Red Hat Linux (6.5-15.fc6rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
warning: the debug information found in
"/usr/lib/debug//usr/bin/fontforge.debug" does not match "/usr/bin/fontforge"
(CRC mismatch).

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) r
Starting program: /usr/bin/fontforge lohit_ta.ttf
(no debugging symbols found)
(no debugging symbols found)
warning: the debug information found in
"/usr/lib/debug//usr/lib/libgdraw.so.1.0.12.debug" does not match
"/usr/lib/libgdraw.so.1" (CRC mismatch).

(no debugging symbols found)
warning: the debug information found in
"/usr/lib/debug//usr/lib/libgunicode.so.2.0.3.debug" does not match
"/usr/lib/libgunicode.so.2" (CRC mismatch).

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
Copyright (c) 2000-2006 by George Williams.
 Executable based on sources from 20:02 25-Oct-2006.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)

Program received signal SIGSEGV, Segmentation fault.
0x02249e48 in u_strlen () from /usr/lib/libgunicode.so.2
(gdb) 
Comment 6 Parag Nemade 2006-12-21 23:09:53 EST
(In reply to comment #3)
> I still cannot make fontforge crash. Please do as instructed in comment #1 and
> attach a report.

strange and funny. I successfully reproduced above problem on FC6 on 2 different
machines and even on RHEL systems also.
Comment 7 Parag Nemade 2006-12-21 23:11:19 EST
bt command gave me
(gdb) bt
#0  0x02249e48 in u_strlen () from /usr/lib/libgunicode.so.2
#1  0x081b2712 in MenuRecentBuild ()
#2  0x081b2930 in WindowMenuBuild ()
#3  0x080eb8cd in FVChangeDisplayBitmap ()
#4  0x00822f5e in GMenuBarSetItemEnabled () from /usr/lib/libgdraw.so.1
#5  0x00825a08 in GMenuPopupCheckKey () from /usr/lib/libgdraw.so.1
#6  0x007f4ae9 in GWidgetIndicateFocusGadget () from /usr/lib/libgdraw.so.1
#7  0x007f4c0e in GWidgetIndicateFocusGadget () from /usr/lib/libgdraw.so.1
#8  0x0084079a in _XSyncScreen () from /usr/lib/libgdraw.so.1
#9  0x0084200a in _XSyncScreen () from /usr/lib/libgdraw.so.1
#10 0x007f69b4 in GDrawEventLoop () from /usr/lib/libgdraw.so.1
#11 0x0819e532 in FontForgeMain ()
#12 0x0805ec72 in main ()
Comment 8 Parag Nemade 2006-12-24 01:55:21 EST
Do you need any other information from me about this problem?
Comment 9 Kevin Fenzi 2006-12-29 19:08:44 EST
Hey Parag. 

I also can't get this to happen here... 

I wonder from your backtrace if it's something to do with locale handling. 
If you launch fontforge with: 

export LANG=en_US.UTF-8 ; fontforge ... 

does it still crash?

Comment 10 Kevin Fenzi 2007-02-28 23:16:09 EST
Hey Parag. 

Did you have a chance to try the suggestion from comment #9?
Also, I think we now have a newer fontforge out, can you see if it still happens
there?
Comment 11 Parag Nemade 2007-06-14 08:53:18 EDT
not found on F7 so closing.

Note You need to log in before you can comment on or make changes to this bug.