Bug 220315 - Eclipse Search Fails on Fedora Core 6
Summary: Eclipse Search Fails on Fedora Core 6
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Ben Konrath
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-20 11:54 UTC by dave
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-30 20:50:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file (1.08 MB, text/plain)
2006-12-20 11:54 UTC, dave
no flags Details

Description dave 2006-12-20 11:54:06 UTC
Description of problem:
Eclipse Search utility fails to find *any* results even when file with text
exists. Tried searching for * and in all filetypes for all workspace but no
luck. Same problem with non-fedora eclipse. Tried a test with the fresh core
installation of eclipse with no plugins still same problem.


Version-Release number of selected component (if applicable):
Eclipse 3.2 Fedora Core 6 2.6.18-1.2868.fc6



How reproducible:


Steps to Reproduce:
1.Open fedora eclipse and create project with text file test.txt with text 'xxx'
2.Do Search > File >File Search Containing text 'x' File name patterns '*' or
'*.*' Scope workspace or current selection
3.Click search 
  
Actual results:
No search results found


Expected results:
Test.txt should have been identified

Additional info:

Have premissions to files etc have tried running under root to no avail

Comment 1 dave 2006-12-20 11:54:07 UTC
Created attachment 144091 [details]
Log file

Comment 2 Andrew Overholt 2006-12-20 13:50:35 UTC
This *could* be a duplicate of bug #183698.  I'll see if I can install that and
verify that it's fixed there.

Comment 3 Andrew Overholt 2006-12-20 13:53:49 UTC
Wow, looking at your log it looks like you've installed a few things from update
sites.  It'd be cool if you could report on fedora-devel-java-list how things
like WTP work on the free stack.  A cursory glance indicates at least one GNU
XML issue  and what appears to be a bug in WTP somewhere with it trying to write
to the install location.

Comment 4 Ben Konrath 2006-12-20 16:15:40 UTC
(In reply to comment #0)
> Description of problem:
> Eclipse Search utility fails to find *any* results even when file with text
> exists. Tried searching for * and in all filetypes for all workspace but no
> luck. Same problem with non-fedora eclipse. Tried a test with the fresh core
> installation of eclipse with no plugins still same problem.

When you tried the upstream Eclipse, did you use a proprietary VM? If so, this
is  an upstream bug and it should be filed there. Thanks.

Comment 5 dave 2006-12-20 16:48:18 UTC
I removed the libgcj of gnu java dispatched with fedora with suns 1.5.0.9 and
resolved the problem

http://ccl.net/cca/software/SOURCES/JAVA/JSDK-1.5/index.shtml

Comment 6 Ben Konrath 2006-12-20 17:50:09 UTC
Ok, then it's probably a libgcj bug. I don't have time to track this down but it
would be really helpful if you could do it. Here are some instructions:

http://wiki.eclipse.org/index.php/Debugging_Eclipse_GCJ_Problems

Let me know if you have any questions. Thanks.

Comment 7 Ben Konrath 2007-04-27 06:33:32 UTC
FWIW, this is fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.