Bug 220333 - Opal does not send proper duration for RFC2833 DTMF
Opal does not send proper duration for RFC2833 DTMF
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: opal (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-20 09:38 EST by Andrew Rechenberg
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-20 12:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Asterisk non-working RTP debug output (55.82 KB, text/plain)
2006-12-20 09:41 EST, Andrew Rechenberg
no flags Details
Asterisk working RTP debug output (48.93 KB, text/plain)
2006-12-20 09:43 EST, Andrew Rechenberg
no flags Details
Patch to fix broken RFC2833 DTMF packets in opal 2.2.2 (1.08 KB, patch)
2006-12-20 09:45 EST, Andrew Rechenberg
no flags Details | Diff
Patch to fix broken RFC2833 DTMF packets in opal 2.2.3 (1.39 KB, patch)
2006-12-20 09:46 EST, Andrew Rechenberg
no flags Details | Diff

  None (edit)
Description Andrew Rechenberg 2006-12-20 09:38:40 EST
Description of problem:
Using opal-2.2.2 with ekiga-2.0.2, ekiga sends RFC2833 DTMF RTP packets with a
zero duration to a SIP registrar or server.  If the registrar or server doesn't
use a loose interpretation of SIP then the DTMF digits are discarded so Ekiga
can't be used to control a voicemail system during a SIP call.

Version-Release number of selected component (if applicable):
2.2.2
2.2.3

How reproducible:
Everytime

Steps to Reproduce:
1. Create a SIP extension on a soft PBX (I used asterisk 1.4.0-beta4)
2. Connect Ekiga using opal 2.2.2 or 2.2.3 to the soft PBX
3. Make a call to another system or PBX voicemail system and try to send DTMF
digits to control the system.
  
Actual results:
System does not respond to DTMF digits due to zero duration and no "end" RTP packet

Expected results:
RTP packets should have a non-zero duration and an "end 1" packet should be sent
and the system should respond to those DTMF digits

Additional info:
This problem occurs with the current opal for Fedora Core 6 as well as opal for
devel/rawhide.

I will attach debug outputs and patches.  My patches are a combination of the
following:

http://openh323.cvs.sourceforge.net/openh323/opal/src/codec/rfc2833.cxx?r1=2.2&r2=2.2.2.1&view=patch
http://openh323.cvs.sourceforge.net/openh323/opal/src/sip/sipcon.cxx?r1=2.120.2.19&r2=2.120.2.20&view=patch
Comment 1 Andrew Rechenberg 2006-12-20 09:41:34 EST
Created attachment 144103 [details]
Asterisk non-working RTP debug output

This patch shows non-working DTMF RTP packets from Ekiga 2.0.2 to an Asterisk
1.4.0-beta4 software PBX.  Note the zero duration packets with no "end 1"
packet.
Comment 2 Andrew Rechenberg 2006-12-20 09:43:26 EST
Created attachment 144105 [details]
Asterisk working RTP debug output

This file shows the debug output from working DTMF RTP packets after patches
were applied to opal.
Comment 3 Andrew Rechenberg 2006-12-20 09:45:27 EST
Created attachment 144106 [details]
Patch to fix broken RFC2833 DTMF packets in opal 2.2.2
Comment 4 Andrew Rechenberg 2006-12-20 09:46:00 EST
Created attachment 144107 [details]
Patch to fix broken RFC2833 DTMF packets in opal 2.2.3
Comment 5 Andrew Rechenberg 2006-12-20 09:49:14 EST
Comment #1 should read "this file" not "this patch"

For more information on this opal issue refer to:

http://bugzilla.gnome.org/show_bug.cgi?id=327988
Comment 6 Daniel Veillard 2006-12-20 10:10:23 EST
Okay if those are patches from Damien, sur I will push them,

Daniel
Comment 7 Andrew Rechenberg 2006-12-20 10:36:48 EST
Those patches are directly from the opal cvs on sourceforge.net and if this is
the same Damien:

http://bugzilla.gnome.org/show_bug.cgi?id=327988#c14

then they are from him :)
Comment 8 Daniel Veillard 2006-12-20 12:22:30 EST
Okay I have pushed opal-2.2.3-4.fc7 to rawhide with the patches
and opal-2.2.2-2 will go soon into Fedora Core 6 testing updates,

  thanks !

Daniel

Note You need to log in before you can comment on or make changes to this bug.