Bug 220336 - Netstat segfaults
Netstat segfaults
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-tools (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-20 09:58 EST by Anand
Modified: 2008-08-27 03:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-27 03:49:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Netstat Core file (1.60 MB, application/octet-stream)
2007-02-01 14:04 EST, Anand
no flags Details

  None (edit)
Description Anand 2006-12-20 09:58:15 EST
Description of problem:
Netstat segfaults

Version-Release number of selected component (if applicable):
Name        : net-tools                    Relocations: (not relocatable)
Version     : 1.60                              Vendor: Red Hat, Inc.
Release     : 37.EL4.8                      Build Date: Wed 07 Jun 2006 03:45:41
AM PDT
Install Date: Fri 11 Aug 2006 12:56:02 AM PDT      Build Host:
hs20-bc1-5.build.redhat.com
Group       : System Environment/Base       Source RPM:
net-tools-1.60-37.EL4.8.src.rpm
Size        : 733833                           License: GPL
Signature   : DSA/SHA1, Wed 07 Jun 2006 07:43:52 AM PDT, Key ID 219180cddb42a60e
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Basic networking tools.


How reproducible:
/bin/netsat

Steps to Reproduce:
1. running netstat in a shell window as root
2.
3.
  
Actual results:
etstat
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address               Foreign Address             State
Segmentation fault


Expected results:


Additional info:
I have installed RedHat GFS and Cluster suite as well on these machines. All of
the machines in the cluster suffer from this.
Comment 1 Radek Vokal 2006-12-20 10:21:02 EST
Can you please install debuginfo package and give me the core dump. Also it
would be better if you go to our support with this issue first. 
Comment 2 Anand 2006-12-20 10:38:33 EST
According to up2date there is not package called debuginfo. 
Also how would I go about contacting support ? 
Comment 3 Radek Vokal 2006-12-20 10:57:44 EST
I guess you need to set RHN for debuginfo packages somehow... well, that's what
support is for. Use your customer login and password

https://www.redhat.com/apps/support/

Comment 4 Anand 2007-01-16 15:57:36 EST
I am sorry, but can someone please tell me where I can get the rpms so I can
download and install them either from up2date or just put it into Bugzilla here.
I can't seem to find a way to get the packages to resolve this ticket. I
enebaled up2date in debug and no such luck. 
-Anand 
Comment 6 Radek Vokal 2007-02-01 09:27:36 EST
or you might try up2date install net-tools-debuginfo
Comment 7 Radek Vokal 2007-02-01 09:34:31 EST
ok, the correct answer is different. There are no debuginfo packages in RHN for
RHEL4 so you need to install the debuginfo package by hand from one of the ftp
mirrors

ftp://ftp.redhat.com/pub/redhat/linux/enterprise/4/en/os/

Comment 8 Anand 2007-02-01 13:08:22 EST
I installed the net-tools-debuginfo. Now what do I need to run to get this to
give  a core dump?
Comment 9 Radek Vokal 2007-02-01 13:17:19 EST
run
$ulimit -c unlimited
$nestat

and send me the .core file you will get when netstat segfaults.

Comment 10 Anand 2007-02-01 14:04:59 EST
Created attachment 147129 [details]
Netstat Core file 

Netstat core file
Comment 11 Anand 2007-02-15 16:23:53 EST
Any update ont eh status of this?
-Ananda 
Comment 12 Radek Vokal 2007-05-22 09:33:07 EDT
Hi Anand, can you please try rebuilding net-tools from Fedora devel. I believe
the issue I saw there with multiple interfaces will fix your issue as well.
Comment 13 Anand 2007-05-22 14:11:38 EDT
Actually one of our sys-admins found a bad entry in the nsswitch.conf file.
We believe the entry 
   services: files nis 
was wrong and changing it to 
   services: files 
then restarting ypbind fixed the issue.
fixed the issue. 


Looks like when netstast runs it reads the services line and sees nis and it
remains in an unfinished state. 
-Anand
Comment 14 Radek Vokal 2007-05-23 09:46:02 EDT
Hmm, even with this line in nsswitch.conf and ypbind/ypserv running on localhost
I can't reproduce the crash.
Comment 15 Radek Vokal 2007-05-23 09:56:07 EDT
Are there any other changes in you nsswitch.conf file? Also you yp.conf file
might be useful for me.
Comment 16 Anand 2007-06-21 20:19:31 EDT
This might be an issue with our ypservers.

Note You need to log in before you can comment on or make changes to this bug.