Bug 220356 - booty does not persists certain kernel params
booty does not persists certain kernel params
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: booty (Show other bugs)
4.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Peter Jones
Robert M Williams
: EasyFix, HardwareEnablement, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-20 12:12 EST by Guil Barros
Modified: 2010-10-22 03:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0681
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:35:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to bootloaderInfo.py in booty-0.31.2-1.i386.rpm (602 bytes, patch)
2006-12-21 09:56 EST, Guil Barros
no flags Details | Diff
patch to bootloaderInfo.py in booty-0.44.4-1.i386.rpm (580 bytes, patch)
2006-12-21 10:12 EST, Guil Barros
no flags Details | Diff
patch to bootloaderInfo.py in booty-0.80-1.i386.rpm (632 bytes, patch)
2006-12-21 10:13 EST, Guil Barros
no flags Details | Diff
patch to bootloaderInfo.py in booty-0.44.4-1.i386.rpm (568 bytes, patch)
2007-12-12 16:12 EST, Guil Barros
no flags Details | Diff
patch to bootloaderInfo.py in booty-0.80-1.i386.rpm (620 bytes, patch)
2007-12-12 16:13 EST, Guil Barros
no flags Details | Diff
patch to bootloaderInfo.py in booty-0.31.2-1.i386.rpm (590 bytes, patch)
2007-12-12 16:50 EST, Guil Barros
no flags Details | Diff

  None (edit)
Description Guil Barros 2006-12-20 12:12:38 EST
Description of problem:
booty is reponsible for adding kernel params used during install into grub.conf
but it does not do so for all params. Specifically "clock=", "pci=", and
"console=" are useful ones that should arguably persist.

Version-Release number of selected component (if applicable):
All pre-0.8 for "pci=". All for others.

  
Actual results:
"clock=", "pci=", and "console=" do not get added to grub.conf after install

Expected results:
They should be copied over from syslinux at install-time.

Additional info:
"pci=nommconf" is required for a number of AMD hardware to run correctly, and as
such should persist.

"clock=" is required to make sure vmware virtual machines pick the correct
timer, and so that the correct timer is used on certain AMD hardware. In RHEL4
it correctly picks HPET if available, default is TSC. VMWare virtual machines
should use PIT to avoid excessive clock skew.

"console=" seems to persist in RHEL4 but not in RHEL3, yet it is not listed in
booty:ourargs.
Comment 1 Guil Barros 2006-12-21 09:56:27 EST
Created attachment 144185 [details]
patch to bootloaderInfo.py in booty-0.31.2-1.i386.rpm
Comment 2 Guil Barros 2006-12-21 10:12:40 EST
Created attachment 144190 [details]
patch to bootloaderInfo.py in booty-0.44.4-1.i386.rpm
Comment 3 Guil Barros 2006-12-21 10:13:48 EST
Created attachment 144191 [details]
patch to bootloaderInfo.py in booty-0.80-1.i386.rpm
Comment 6 Peter Jones 2007-12-11 13:10:12 EST
The patch here isn't really correct, in that "console=" is already handled,
though through a different mechanism due to its use of multiple arguments in
combination and their effect on the install process itself.  See the
BootloaderInfo class's __init__ method and then later the use of
self.serialDevice in the writeGrub method.  Adding specific arguments related to
console needs to be done in that code rather than with "ourargs".
Comment 8 Guil Barros 2007-12-12 16:12:31 EST
Created attachment 286171 [details]
patch to bootloaderInfo.py in booty-0.44.4-1.i386.rpm

updated original patch to remove reference to "console=" as per comment.
Comment 9 Guil Barros 2007-12-12 16:13:41 EST
Created attachment 286181 [details]
patch to bootloaderInfo.py in booty-0.80-1.i386.rpm

updated original patch to remove reference to "console=" as per comment.
Comment 10 Guil Barros 2007-12-12 16:50:01 EST
Created attachment 286221 [details]
patch to bootloaderInfo.py in booty-0.31.2-1.i386.rpm

updated to remove "console="
Comment 11 Peter Jones 2008-02-12 15:38:12 EST
Fixed in booty-0.44.7-1 .
Comment 12 Peter Jones 2008-02-14 16:00:09 EST
Actually, it'll be 0.44.8-1 .
Comment 14 Alexander Todorov 2008-06-06 05:41:45 EDT
Guil,
fix for this should be available in RHEL4-U7 snapshot #2. Please work with the
customer to verify that the bug has been fixed. Please post you comments to this
bug.

Thanks.
Comment 15 Robert M Williams 2008-06-06 12:38:45 EDT
verified fixed in rhel4-u7 snapshot 2
Comment 17 errata-xmlrpc 2008-07-24 15:35:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0681.html

Note You need to log in before you can comment on or make changes to this bug.