Bug 22037 - RFE: upgrade to trn4
RFE: upgrade to trn4
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: trn (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-10 15:54 EST by Chris Adams
Modified: 2014-03-16 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-25 21:23:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2000-12-10 15:54:30 EST
Please consider upgrading to trn4 in the next release.  It is
much more "modern" and feature-ful.  It is available from
http://trn.sourceforce.net/
Comment 1 Jeff Johnson 2000-12-23 10:08:02 EST
trn4 appears to be still in beta, deferred until final relase of trn4.
Comment 2 Chris Adams 2000-12-23 13:36:39 EST
It is a beta only in the documentation really.  The docs haven't
been 100% updated yet.  Otherwise, the program is solid and
stable (I've been using trn4 exclusively for a couple of years
now, including on shell servers at the ISPs I've worked for).
Comment 3 Chris Adams 2001-04-25 21:23:20 EDT
I'd like to reopen this, since trn 3.6 has been dropped due to license issues. 
Is the license from trn version 4 acceptable?  Here it is:

************************************************************************
This software is Copyright (C) 1991-2000 by Wayne Davison. 
Portions Copyright (C) by Clifford A. Adams, Stan Barber, Larry Wall,
and others.  All rights reserved.

Permission is hereby granted to copy, reproduce, redistribute or
otherwise use this software as long as:  there is no monetary profit
gained specifically from the use or reproduction of this software, it
is not sold, rented, traded or otherwise marketed, and this copyright
notice is included prominently in any copy made.  Software bundlers
who include trn among other diverse applications are exempt from this
restriction, as long as the distribution includes trn's source code
(including this license).

The authors make no claims as to the fitness or correctness of this
software for any use whatsoever, and it is provided as is. Any use of
this software is at the user's own risk.
************************************************************************

If not, what kind of changes would be necessary?

Also, since the software is only beta because the documentation hasn't been
updated to include the new features (the code is functional and works), I don't
see why it being named "beta" is a problem (especially since Red Hat Linux 7.1
includes development versions of software like vim and lynx).
Comment 4 Trond Eivind Glomsrxd 2001-04-26 11:05:44 EDT
It doesn't mention "modify" among what you have the right to do, and it's also
restrictive in that you can't make money of it (it's somewhat better since it
now applies to it specifically, but it's still not an open source license.

Note You need to log in before you can comment on or make changes to this bug.