Bug 220396 - Importing a "project from existing sources" does not work.
Importing a "project from existing sources" does not work.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anjuta (Show other bugs)
8
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-20 17:30 EST by Bryan Christ
Modified: 2008-07-16 15:17 EDT (History)
1 user (show)

See Also:
Fixed In Version: anjuta-2.2.3-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 15:17:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Christ 2006-12-20 17:30:34 EST
Description of problem:

Anjta gives the following error message when trying to import an existing project...

Could not find a valid project backend for the directory given
(/home/bchrist/devel/helloworld). Please select a different directory, or try
upgrading to a newer version of the Gnome Build Framework.

Version-Release number of selected component (if applicable):

rpm -qa |grep anjuta
anjuta-gdl-0.6.1-5.fc6
anjuta-docs-2.0.2-11.fc6
anjuta-2.0.2-11.fc6

How reproducible:

Everytime

Steps to Reproduce:
1.  Using the menu item New->Project from existing sources, try to import an
existing C/C++ project
2.
3.
  
Actual results:

Error message

Expected results:

New project

Additional info:
Comment 1 Paul F. Johnson 2007-01-21 06:52:03 EST
Can you have a look and see if the version in rawhide fixes this problem? You'll
need to also update anjuta-gdl and gnome-build. If it works, I'll give it a week
for it to settle down and import and build for core.
Comment 2 Bryan Christ 2007-01-22 11:29:50 EST
Here's what I installed:

rpm -Uvh anjuta-2.1.0-1.fc7.i386.rpm anjuta-gdl-0.7.0-1.fc7.i386.rpm
gnome-build-0.1.4-2.fc7.i386.rpm anjuta-docs-2.1.0-1.fc7.i386.rpm
graphviz-2.12-2.fc7.i386.rpm

I still get the same error message.
Comment 3 Marc Maurer 2007-07-21 08:44:01 EDT
FYI: they disabled this in anjuta intentionally, as it wasn't working properly.
Comment 4 Debarshi Ray 2008-03-31 10:17:12 EDT
Reassigning to myself since I own this package now.
Comment 5 Bug Zapper 2008-04-04 01:19:05 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 6 Bryan Christ 2008-04-04 10:48:18 EDT
Marc, Debarshi,

Has this feature been reinstated (since comment #3).  If so, I will test it on
Fedora 8.  

Bryan
Comment 7 Debarshi Ray 2008-04-05 14:25:33 EDT
Importing a project from existing sources works for me on anjuta-2.2.3-5. You
can take it from the updates-testing repositories for F-8. Alternatively you can
grab the package from: http://koji.fedoraproject.org/koji/packageinfo?packageID=1302

If it works, you might want to give a positive karma to the anjuta-2.2.3-5
package here:
https://admin.fedoraproject.org/updates/anjuta

Let us know how it turned out for you.
Comment 8 Bryan Christ 2008-04-11 10:58:32 EDT
Retested with package: anjuta-2.2.3-6.fc8.i386.rpm

I got this error message when trying to import:

Could not find a valid project backend for the directory given
(/home/bchrist/devel/hiwire/hwclient). Please select a different directory, or
try upgrading to a newer version of the Gnome Build Framework.
Comment 9 Debarshi Ray 2008-04-12 09:00:06 EDT
(In reply to comment #8)

What build-system are you using in the projects that you are trying to import?

Can you upload a tarball of /home/bchrist/devel/hiwire/hwclient somewhere on the 
Internet?
Comment 10 Debarshi Ray 2008-07-16 15:17:24 EDT
If the problem persists or reoccurs feel free to re-open this bug.

Note You need to log in before you can comment on or make changes to this bug.