Bug 220409 - xm gives python traceback when trying pwd is /etc/xen
xm gives python traceback when trying pwd is /etc/xen
Status: CLOSED DUPLICATE of bug 220408
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-20 20:38 EST by Jim Dennis
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 02:18:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Dennis 2006-12-20 20:38:13 EST
Description of problem:

The xm create command gives the following Python traceback when attempting 
create a domain when the invocation occurs from within the /etc/xen directory:


cd /etc/xen && xm create foo
Using config file "foo".
/usr/lib/python2.4/site-packages/xen/xm/opts.py:520: DeprecationWarning: Non-
ASCII character '\xeb' in file foo on line 1, but no encoding declared; see 
http://www.python.org/peps/pep-0263.html for details
  execfile(defconfig, globs, locs)
Error: invalid syntax (foo, line 1)



Version-Release number of selected component (if applicable): xen-3.0.3-8.el5


How reproducible: 

trivially

Steps to Reproduce:

1. 
    Create a domU (named $foo)

2.
    cd /etc/xen

3.
    xm create $foo

  
Actual results:

Using config file "foo".
/usr/lib/python2.4/site-packages/xen/xm/opts.py:520: DeprecationWarning: Non-
ASCII character '\xeb' in file foo on line 1, but no encoding declared; see 
http://www.python.org/peps/pep-0263.html for details
  execfile(defconfig, globs, locs)
Error: invalid syntax (foo, line 1)


Expected results:

Using config file "/etc/xen/foo"
Started domain foo


Additional info:
Comment 1 Daniel Veillard 2006-12-21 02:18:35 EST

*** This bug has been marked as a duplicate of 220408 ***

Note You need to log in before you can comment on or make changes to this bug.