Bug 220426 - Incorrect coding category generated in site-start.el
Incorrect coding category generated in site-start.el
Status: CLOSED DUPLICATE of bug 213582
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-21 02:35 EST by Torsten Ekedahl
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-01 20:08:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Torsten Ekedahl 2006-12-21 02:35:43 EST
Description of problem:
site-start.el constructs an invalid coding-system parameter

Version-Release number of selected component (if applicable):
21.5.27

How reproducible:
Very

Steps to Reproduce:
1. Start xemacs
2. A fatal error during reading of site-start.el stops the 
reading of init-files with error message
'Invalid constant: Unrecognized coding category, iso-8859-1'
3.
  
Actual results:
Reading of init files stops

Expected results:
Reading of init files...

Additional info:

One (not completely satisfactory) fix is to make the following change in
site-start.el

(let* ((tmp (shell-command-to-string "locale charmap"))
           (tmp (substring tmp 0 (string-match "\[ \t\n\]" tmp)))
+           (tmp (replace-in-string tmp "8859" "8"))
           (tmp (intern (downcase tmp))))
      (when (find-coding-system tmp)
        (set-coding-priority-list (list tmp))
        (set-coding-category-system tmp tmp)
        (set-default-output-coding-systems tmp)
        (set-keyboard-coding-system tmp)
        (set-terminal-coding-system tmp)
        (setq file-name-coding-system tmp)
        (setq process-coding-system-alist (cons (cons ".*" tmp) '()))
        (define-coding-system-alias 'native tmp)))

(Apparently the proper name for the coding-system is 'iso-8-1' and not
'iso-8859-1')
Comment 1 Ville Skyttä 2007-01-01 20:08:50 EST
See bug 213582, this looks the same.  In that bug, I'm waiting for user feedback
whether the patch posted there fixes the issue (which should happen in non-UTF-8
locales only, and in a subset of them) - your feedback is most welcome too.

*** This bug has been marked as a duplicate of 213582 ***

Note You need to log in before you can comment on or make changes to this bug.