Bug 220456 - Can't import AuditMsg
Summary: Can't import AuditMsg
Status: CLOSED DUPLICATE of bug 220460
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-21 14:47 UTC by Tom London
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 20:41:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom London 2006-12-21 14:47:11 UTC
Description of problem:
After update to setroubleshoot-1.8.12-1.fc7:

Traceback (most recent call last):
  File "/usr/sbin/setroubleshootd", line 71, in <module>
    from setroubleshoot.server import RunFaultServer
  File "/usr/lib/python2.5/site-packages/setroubleshoot/server.py", line 35, in
<module>
    from setroubleshoot.analyze import *
  File "/usr/lib/python2.5/site-packages/setroubleshoot/analyze.py", line 35, in
<module>
    from setroubleshoot.avc_audit import *
  File "/usr/lib/python2.5/site-packages/setroubleshoot/avc_audit.py", line 20,
in <module>
    import AuditMsg
ImportError: No module named AuditMsg


Version-Release number of selected component (if applicable):
setroubleshoot-1.8.12-1.fc7

How reproducible:
every time

Steps to Reproduce:
1. install
2. start
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2006-12-21 14:51:24 UTC
[tbl@localhost site-packages]$ cd /usr/lib/python2.4/site-packages
[tbl@localhost site-packages]$ ls
AuditMsg.py  AuditMsg.pyc  AuditMsg.pyo  dbus  GMenuSimpleEditor
[tbl@localhost site-packages]$ rpm -qif AuditMsg.py
Name        : audit-libs-python            Relocations: (not relocatable)
Version     : 1.3.1                             Vendor: Red Hat, Inc.
Release     : 1.fc7                         Build Date: Sun 10 Dec 2006 02:54:31
PM PST
Install Date: Tue 12 Dec 2006 06:45:44 AM PST      Build Host:
hs20-bc2-2.build.redhat.com
Group       : Development/Libraries         Source RPM: audit-1.3.1-1.fc7.src.rpm
Size        : 201950                           License: LGPL
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://people.redhat.com/sgrubb/audit/
Summary     : Python bindings for libaudit
Description :
The audit-libs-python package contains the bindings so that libaudit
can be used by python.


Comment 2 Tom London 2006-12-21 15:02:42 UTC
Filed here against audit:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=220460

Comment 3 John Dennis 2006-12-21 20:41:17 UTC

*** This bug has been marked as a duplicate of 220460 ***


Note You need to log in before you can comment on or make changes to this bug.