Bug 220462 - 2.6.19-1.2890.fc7 does not boot on ia64: No sd devices?
2.6.19-1.2890.fc7 does not boot on ia64: No sd devices?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-21 10:14 EST by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 10:18:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-12-21 10:14:15 EST
Description of problem:

2.6.19-1.2890.fc7 does not boot on ia64.  I think the something is hosed with
scsi ....

Version-Release number of selected component (if applicable): 2.6.19-1.2890.fc7 


How reproducible: 100%


Steps to Reproduce:
1.  Boot kernel
  
Actual results:

ehci_hcd 0000:00:01.2: irq 54, io mem 0x80000000
ehci_hcd 0000:00:01.2: USB 2.0 started, EHCI 0.95, driver 10 Dec 2004
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 5 ports detected
Loading mbcache.ko module
Loading jbd.ko module
Loading ext3.ko module
Loading scsi_mod.ko module
SCSI subsystem initialized
Loading sd_mod.ko module
Loading scsi_transport_spi.ko module
Loading mptbase.ko module
Fusion MPT base driver 3.04.02
Copyright (c) 1999-2005 LSI Logic Corporation
Loading mptscsih.ko module
Loading mptspi.ko module
Fusion MPT SPI Host driver 3.04.02
GSI 27 (level, low) -> CPU 1 (0x0100) vector 55
ACPI: PCI Interrupt 0000:20:01.0[A] -> GSI 27 (level, low) -> IRQ 55
mptbase: Initiating ioc0 bringup
ioc0: 53C1030: Capabilities={Initiator,Target}
scsi0 : ioc0: LSI53C1030, FwRev=01032341h, Ports=1, MaxQ=255, IRQ=55
usb 2-2: new low speed USB device using ohci_hcd and address 2
usb 2-2: configuration #1 chosen from 1 choice
GSI 28 (level, low) -> CPU 0 (0x0000) vector 56
ACPI: PCI Interrupt 0000:20:01.1[B] -> GSI 28 (level, low) -> IRQ 56
mptbase: Initiating ioc1 bringup
 target0:0:0: mpt_config failed
ioc1: 53C1030: Capabilities={Initiator,Target}
scsi1 : ioc1: LSI53C1030, FwRev=01032341h, Ports=1, MaxQ=255, IRQ=56
scsi 0:0:0:0: Direct-Access     HP 73.4G MAX3073NC        HPC1 PQ: 0 ANSI: 3
 target0:0:0: Beginning Domain Validation
 target0:0:0: Ending Domain Validation
 target0:0:0: FAST-160 WIDE SCSI 320.0 MB/s DT IU QAS RTI WRFLOW PCOMP (6.25 ns,
 offset 127)
scsi 0:0:1:0: Direct-Access     HP 73.4G MAX3073NC        HPC1 PQ: 0 ANSI: 3
 target0:0:1: Beginning Domain Validation
 target0:0:1: Ending Domain Validation
 target0:0:1: FAST-160 WIDE SCSI 320.0 MB/s DT IU QAS RTI WRFLOW PCOMP (6.25 ns,
 offset 127)
Loading dm-mod.ko module
device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised: dm-devel@redhat.com
Loading dm-mirror.ko module
Loading dm-zero.ko module
Loading dm-snapshot.ko module
Making device-mapper control node
Scanning logical volumes
  Reading all physical volumes.  This may take a while...
  No volume groups found
Activating logical volumes
  Volume group "VolGroup01" not found
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such filKernel panic - not syncing: Attempte
d to kill init!
e or directory

Expected results: Kernel should boot.


Additional info: Seen on rx2620
Comment 1 Doug Chapman 2007-01-02 13:25:38 EST
It appears I see the same thing with the upstream 2.6.19 kernel.  I will try to
narrow down where this broke upstream.

Comment 2 Doug Chapman 2007-01-02 15:02:54 EST
Please ignore my comment #1.  the upstream kernel I built didn't boot due to a
configuration mistake on my part.  I have now successfully booted 2.6.19.

I really should be more careful about doing things after a long vacation!
Comment 3 Doug Chapman 2007-01-02 15:38:03 EST
I tried various fc7 kernels:

kernel-2.6.19-1.2864.fc7 hangs on boot (unrelated issue)
kernel-2.6.19-1.2872.fc7 hangs on boot (unrelated issue)

kernel-2.6.19-1.2877.fc7 exhibits the problem Prarit reported here
(as do later 2.6.19 based fc7 kernels)

I need to go back to the 2.6.18 based kernels but it is looking like this crept
in with 2.6.19.  I did not see the problem with upstream 2.6.19 or the latest
2.6.20-rc3.

Comment 4 Doug Chapman 2007-01-03 14:03:49 EST
Appears to be storage device specific.  I tried 2.6.19-1.2904.fc7 on a system
with the root device on /dev/cciss/ and it boots however I have no network
devices due to ifcfg-eth0 being moved to ifcfg-eth0.bak (related? kudzu issue?).

The scsi devices are on an LSI card that uses the mptscsi driver.  The module is
loaded and I do see messages as the drives are found:

SCSI device sda: 143374738 512-byte hdwr sectors (73408 MB)
sda: Write Protect is off
sda: Mode Sense: cf 00 10 08
SCSI device sda: write cache: disabled, read cache: enabled, supports DPO and FU
FUAUA
SCSI device sda: 143374738 512-byte hdwr sectors (73408 MB)
sda: Write Protect is off
sda: Mode Sense: cf 00 10 08
SCSI device sda: write cache: disabled, read cache: enabled, supports DPO and FU
FUAUA
 sda:
sd 0:0:0:0: Attached scsi disk sda

and I do see /dev/sda exists and I can partition it with parted, make a file
system and mount it (once the system is already booted).  I looked at the "init"
script created by mkinitrd and it looks sane in fact the init created for
2.6.20-rc3 (which boots fine) is identical to the one created for the FC7
kernels that don't boot.


Comment 5 Dave Jones 2007-04-23 14:59:48 EDT
this was likely due to the missing loading of scsi_wait_scan in the initrd.
test4 (or current boot.iso's) should have this fixed.

Note You need to log in before you can comment on or make changes to this bug.