Bug 220491 - GFS not on PRUNEFS list in updatedb.conf - should be
GFS not on PRUNEFS list in updatedb.conf - should be
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: slocate (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Brock Organ
: Reopened
Depends On: 221547
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-21 13:48 EST by Sam Folk-Williams
Modified: 2008-12-11 05:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 05:53:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Folk-Williams 2006-12-21 13:48:43 EST
Description of problem:
If updatedb scans a GFS filesystem it causes performance to slow drastically due
to lock contention problems.

Version-Release number of selected component (if applicable):
Any

How reproducible:
Always

Steps to Reproduce:
1. Run updatedb on a GFS filesystem
2. Do a lot of "df" and "ls" commands on the gfs filesystem
3. 
  
Actual results:
Eventually df and ls will start to hang/go extremely slow

Expected results:
df and ls should return as normal

Solution:
Add "gfs" and "gfs2" to the PRUNEFS list in /etc/updatedb.conf


Additional info:
Comment 1 RHEL Product and Program Management 2008-02-01 14:10:53 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Steve Whitehouse 2008-12-10 10:41:53 EST
This bug seems to have been forgotten. Bringing it up to the latest RHEL version. I know we've missed 5.3, so lets aim for 5.4.
Comment 3 Steve Whitehouse 2008-12-10 11:42:53 EST
Hmm, just found the bug for 5.4 as well. So we don't need this one then I think.

*** This bug has been marked as a duplicate of bug 221547 ***
Comment 4 Miloslav Trmač 2008-12-11 05:03:03 EST
This was originally filed against RHEL4, so closing as a duplicate of a RHEL5 bug would lose the RHEL4 bug.

Reopening - if you don't care about RHEL4 any more, please say so explicitly.
Comment 5 Steve Whitehouse 2008-12-11 05:18:51 EST
There is no point in adding gfs2 to the list in RHEL4, because gfs2 does not (and will not) ever be a part of RHEL4. Since this bug has been open for two years with apparently no progress even though its a trivial change, I'd rather given up hope of it happening. Is there a reason that its taken so long? Can we speed this process up somehow?
Comment 6 Miloslav Trmač 2008-12-11 05:53:40 EST
(In reply to comment #5)
> There is no point in adding gfs2 to the list in RHEL4, because gfs2 does not
> (and will not) ever be a part of RHEL4.
Thanks, closing this.

> Since this bug has been open for two
> years with apparently no progress even though its a trivial change, I'd rather
> given up hope of it happening. Is there a reason that its taken so long? Can we
> speed this process up somehow?
One reason is that I don't want to release this default configuration change as a fastrack update (to at least give the users a chance to read about it in release notes); there was at least one fastrack mlocate update since filing the bugs.

I'm afraid it seems this very small update is not - or seems not to be - that important when compared to other possible package updates in a RHEL update release.

Note You need to log in before you can comment on or make changes to this bug.