Bug 220492 - BIOS BUG MCFG for PCI
BIOS BUG MCFG for PCI
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-21 14:07 EST by Martin
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-19 16:51:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin 2006-12-21 14:07:26 EST
+++ This bug was initially created as a clone of Bug #198117 +++

After installing 2.6.17-1.2145_FC5smp and also checking it out with 32 bit
non-smp and with 64 bit, I am getting the following:

ACPI: bus type pci registered
PCI: BIOS Bug: MCFG area is not E820-reserved
PCI: Not using MMCONFIG.
PCI: Using configuration type 1
Setting up standard PCI resources

First time ever for the MCFG message and the follow up about MMCONFIG.

Note: to eliminate the Mother board, 
I upgraded Intel bios, Mother board is a d945gnt with bios upgrade to May 2006.

From dmesg
ACPI: MCFG (v001 INTEL D945GNT 0x00000f5a MSFT 0x01000013) @ 0x3f6f6f10


Is it an informative message, an error message, or a bios problem.


Version-Release number of selected component (if applicable):
2.6.17-1.2145_FC5smp

How reproducible:
boot to fc5 non smp, fc5smp or fc5 64 bit.

Note. Message not present in preceding kernel version

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

-- Additional comment from konradr@redhat.com on 2006-07-20 12:51 EST --
The reason you see this message is b/c your machine implements MMCONFIG.
Unfortunatly, some Intel motherboards implemented this wrongly and Linux kernel
would crash. To boot up on those boards without crashing, the kernel checks to
see if the address specified in the ACPI MCFG area is also reserved in E820 area
(which btw, is not something the ACPI v3.0 and PCI Express spec mandates - it is
optional). This is short-term fix and once a better solution is found the
mainline kernel will have that (and FC will have it too)

So for right pls ignore it. It should eventually go away when main-line finds a
proper fix.
Comment 1 Martin 2006-12-21 14:12:43 EST
same error here on a ASUS P5WDG2 Motherboard with kernel 2.6.18-1.2868.fc6 i686

Dec 21 18:11:24 gecko2 kernel: PCI: BIOS Bug: MCFG area at f0000000 is not
E820-reserved
Dec 21 18:11:24 gecko2 kernel: PCI: Not using MMCONFIG.
Dec 21 18:11:24 gecko2 kernel: PCI: PCI BIOS revision 3.00 entry at 0xf0031,
last bus=6
Dec 21 18:11:24 gecko2 kernel: PCI: Using configuration type 1
Dec 21 18:11:24 gecko2 kernel: Setting up standard PCI resources
Dec 21 18:11:24 gecko2 kernel: ACPI: Interpreter enabled
Dec 21 18:11:24 gecko2 kernel: ACPI: Using PIC for interrupt routing
Dec 21 18:11:24 gecko2 kernel: ACPI: PCI Root Bridge [PCI0] (0000:00)

BIOS is version 0408
Comment 2 Leslie Satenstein 2006-12-21 22:35:38 EST
Fc6 complaining MB bios now at 2006-12-19 level  MB is intel d945gnt

NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: BIOS Bug: MCFG area at f0000000 is not E820-reserved
PCI: Not using MMCONFIG.
PCI: Using configuration type 1
Setting up standard PCI resources
Allocating PCI resources starting at 40000000 (gap: 3f700000:c0900000)

This bug has been around since FC5. Intel MB d945gnt with 19dec2006 image update.
Problem has been there for at least 5 bios upgrades.
If it is not a problem, then please mask the logging as error
Comment 3 Dave Jones 2007-02-14 19:21:24 EST
it's a bios bug as the text suggests.
I've lowered the severity in CVS so that it won't get printed onscreen during
boot (though it'll still appear in dmesg)
Comment 4 Leslie Satenstein 2007-03-19 19:03:41 EDT
Thank you
Comment 5 Leslie Satenstein 2007-03-19 19:05:34 EDT
Thank you. Surprisingly, Intel does update its bios's, and for my mother board
that bios is dated 6 weeks back (Feb 2007).  Has intel been advised what is the
bug and what they need to do to correct it?  
Comment 6 Konrad Rzeszutek 2007-03-20 17:36:27 EDT
Leslie,

There is an Intel person who is aware of this: Arjan van de Ven, and I believe
he is been making the Intel BIOS folks aware of this - not sure what the status
of that is. 
Comment 7 Leslie Satenstein 2007-03-20 20:09:01 EDT
Arjan, Good luck in expediting the fix. When it is done, please post here that
information, so I can fetch the bios update and do the update of my motherboard.

Note You need to log in before you can comment on or make changes to this bug.