Bug 220543 - Ipod Nano 2G mis-detected by HAL, fails to mount properly
Ipod Nano 2G mis-detected by HAL, fails to mount properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 211787 220773 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-21 19:52 EST by Lev Gelb
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: udev-095-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 06:21:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lev Gelb 2006-12-21 19:52:13 EST
Description of problem:

The latest Ipod Nano (2nd generation) is detected by HAL as a
"via_raid_member" and then fails to auto-mount.

Version-Release number of selected component (if applicable):
0.5.8.1  (both compiles 5 (updates) and 6 (development)

How reproducible:
very.

Steps to Reproduce:
1.  Get ipod nano 2nd generation
2.  plug in via USB
3.  look in hal-device-manager

Actual results:
as above

Expected results:
should see as a mountable disk, and pass it to gnome-mount to mount

Additional info:
This bug has also been observed in Ubuntu, by several different people:
Their bug report, with debian-style patch to 'hal' is:
https://launchpad.net/distros/ubuntu/+source/hal/+bug/66068

There is also discussion of it in the hal archives at freedesktop.org,
http://lists.freedesktop.org/archives/hal/2006-October/006413.html,  which offer
a fix at the kernel level.

Both are dated after the current HAL release (from September)
Comment 1 David Zeuthen 2006-12-21 19:56:06 EST
There's a patch for udev (hal relies on libvolume_id from the udev src.rpm) for
this here

 http://lists.freedesktop.org/archives/hal/2006-October/006412.html

Harald, can you apply this for FC6 please? Also adding Bill Peck as Cc as he
experienced this problem too and said the patch worked fine. Thanks.
Comment 2 Bill Peck 2006-12-22 09:00:03 EST
Yes, I can confirm the patch works, QA ack. ;-)
Comment 3 Joshua Jensen 2006-12-27 23:42:16 EST
Suffering from the same problem here.... new 8gig iPod Nano for Christmas...
doesn't work due to hal thinking "via_raid_member".

Looks like BZ # 220773 is the same as this bug.

Please fix!
Comment 4 David Zeuthen 2007-01-02 15:51:07 EST
*** Bug 220695 has been marked as a duplicate of this bug. ***
Comment 5 David Zeuthen 2007-01-02 15:54:10 EST
*** Bug 220773 has been marked as a duplicate of this bug. ***
Comment 6 Harald Hoyer 2007-01-10 06:09:39 EST
udev-095-17.fc6 will appear in testing 
Comment 7 Joshua Jensen 2007-01-14 21:57:21 EST
Confirmed that the udev fix works.  dmesg now shows this:

SCSI subsystem initialized
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
  Vendor: Apple     Model: iPod              Rev: 1.62
  Type:   Direct-Access                      ANSI SCSI revision: 00
usb-storage: device scan complete
scsi 0:0:0:0: Attached scsi generic sg0 type 0
SCSI device sda: 3964928 2048-byte hdwr sectors (8120 MB)
sda: Write Protect is off
sda: Mode Sense: 68 00 00 08
sda: assuming drive cache: write through
SCSI device sda: 3964928 2048-byte hdwr sectors (8120 MB)
sda: Write Protect is off
sda: Mode Sense: 68 00 00 08
sda: assuming drive cache: write through
 sda: sda1 sda2
sd 0:0:0:0: Attached scsi removable disk sda


"lshal | grep -i ipod" now shows this:

 info.udi = '/org/freedesktop/Hal/devices/storage_serial_Apple_iPod_000A2700192
DBC01'  (string)
  info.product = 'iPod'  (string)
  storage.serial = 'Apple_iPod_000A2700192DBC01'  (string)
  storage.model = 'iPod'  (string)
  block.storage_device = '/org/freedesktop/Hal/devices/storage_serial_Apple_iPod
_000A2700192DBC01'  (string)
etc


Now I just need Banshee and Rhythmbox to understand that it really can access my
8gig iPod Nano :-(
Comment 8 Bill Peck 2007-01-15 10:01:23 EST
I have Banshee working with the 8GB nano fine.  You may need to update libgpod
from freshrpms to support the newer 6th generation ipod.  if libgpod is in
extras we should get it updated there.
Comment 9 Joshua Jensen 2007-01-15 13:08:17 EST
I noticed that libgpod-0.4.2 came out *today*... but can't get it to compile so
I can't tell if that would help me or not.  Perhaps we can get libgpod updated
to this version in Fedora Core 6
Comment 10 Todd Zullinger 2007-01-21 19:43:55 EST
libgpod is available in core.  An update to 0.4.2 is in updates-testing as of
the 17th.  An update for rhythmbox is also in -testing.  Please check those out
and report if they work well with the later iPod Nanos.

For banshee, libgpod isn't a factor AFAIK.  It used libipoddevice and it's own
ipod-sharp lib to access the ipod.
Comment 11 Simone Gotti 2007-05-01 13:17:32 EDT
*** Bug 211787 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.