Bug 220551 - removing sendmail brings in mysql dependancy.
removing sendmail brings in mysql dependancy.
Status: CLOSED DUPLICATE of bug 219920
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-21 20:22 EST by Dave Jones
Modified: 2015-01-04 17:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 02:55:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-12-21 20:22:21 EST
This is bizarre.  I had accidentally removed mutt and sendmail as dependancies
of hesiod. So I thought doing a yum install mutt would bring everything back.
Instead, it decided to bring in exim instead of sendmail, which pulled in mysql!

# yum install mutt
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for mutt to pack into transaction set.
mutt-1.4.2.2-5.fc6.x86_64 100% |=========================|  20 kB    00:00     
---> Package mutt.x86_64 5:1.4.2.2-5.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: /usr/sbin/sendmail for package: mutt
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for exim to pack into transaction set.
exim-4.63-5.fc6.x86_64.rp 100% |=========================|  25 kB    00:00     
---> Package exim.x86_64 0:4.63-5.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: libmysqlclient.so.15()(64bit) for package: exim
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15)(64bit) for
package: exim
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for mysql to pack into transaction set.
mysql-5.0.27-1.fc6.x86_64 100% |=========================|  36 kB    00:00     
---> Package mysql.x86_64 0:5.0.27-1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: perl(DBI) for package: mysql
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for perl-DBI to pack into transaction set.
perl-DBI-1.52-1.fc6.x86_6 100% |=========================|  16 kB    00:00     
---> Package perl-DBI.x86_64 0:1.52-1.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 mutt                    x86_64     5:1.4.2.2-5.fc6  updates-testing   1.2 M
Installing for dependencies:
 exim                    x86_64     4.63-5.fc6       extras            1.2 M
 mysql                   x86_64     5.0.27-1.fc6     updates           3.3 M
 perl-DBI                x86_64     1.52-1.fc6       core              605 k
Comment 1 Miroslav Lichvar 2006-12-22 02:55:20 EST

*** This bug has been marked as a duplicate of 219920 ***

Note You need to log in before you can comment on or make changes to this bug.