Bug 220573 - pre-edit buffer disappearing with mouse click instead of committing
pre-edit buffer disappearing with mouse click instead of committing
Status: CLOSED DUPLICATE of bug 206236
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
  Show dependency treegraph
Reported: 2006-12-21 23:36 EST by Jong Bae KO
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-09 03:13:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jong Bae KO 2006-12-21 23:36:24 EST
Description of problem:
In pre-editing state(Japanese & Chinese), if you click other place, the letter
of pre-editing will be disappeared.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. run gedit with scim
2. type some Janpanese or Chinese
3. make pre-editing state and clicking to other non-preedited letters

Actual results:

Expected results:

Additional info:
Comment 1 Mayank Jain 2007-01-15 04:46:28 EST

I just checked up, Gedit does not uses custom gtk widgets. The text area is a
GtkSourceView widget. All preedit related issues are handled by scim/related-IME's.

To confirm my test, I checked the steps to reproduce with scim-anthy on kedit
and observed the same as mentioned in the bug report.

Adding Jens to the CC list, moving the bug to devel.
Comment 2 Mayank Jain 2007-01-15 04:48:14 EST
Jens, is this a scim bug?
Comment 3 Jens Petersen 2007-01-22 22:05:20 EST
Well it may be scim related, though I'm not sure it is bug.

Actually the behaviour under KDE seems slightly different.
At least in kate preedit does not move or disappear for me.
Perhaps this behaviour is better in this case.

I don't think it is optimal for Japanese or Chinese just to
commit preedit in this case, since usually it is not complete.
This is a difference with Hangul input.
Comment 4 Jong Bae KO 2007-01-22 22:24:54 EST
Hi Jens,

I am not sure this is a bug as well. maybe natives decide this one.
However, I think we are better to make the same behavior on gedit, kedit and
Comment 5 Jens Petersen 2007-10-09 03:13:04 EDT

*** This bug has been marked as a duplicate of 206236 ***

Note You need to log in before you can comment on or make changes to this bug.