Bug 220665 - SuperTux 0.3.0 has been released
SuperTux 0.3.0 has been released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: supertux (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-22 16:30 EST by vfiend
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 12:58:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Steven Pritchard 2007-01-26 15:39:25 EST
So you don't think I'm ignoring this, I've been trying to update the package, 
but upstream chose to switch from make to jam, and their Jamconfig sucks.  (No 
support for DESTDIR, for example.)

This is probably going to take a while...  (It looks really nice though.)
Comment 2 vfiend 2007-01-26 17:18:56 EST
Ah, okay, thanks a lot for your efforts.

And yeah, the new world gives the game a unique flavour.
Comment 3 Steven Pritchard 2007-02-13 12:58:43 EST
So apparently I'm the one who sucks, and I just need to learn how to use 
jam.  ;-)

0.3.0 should be pushed to extras-development soon.  The extras-development 
package installs fine on FC6, so please give it a try.  
("yum --enablerepo=extras-development install supertux")

Upstream considers 0.1.3 "stable" and 0.3.0 "unstable", so I may not push 
0.3.0 to FC6 at all.
Comment 4 Wart 2007-02-14 16:52:47 EST
Are there any savefile compatibility issues when upgrading from 0.1.3 to 0.3.0?
 If so, then I'd be inclined to avoid upgrading in FC6 and leaving the new
version in rawhide/FC7 only.
Comment 5 Steven Pritchard 2007-02-14 17:12:03 EST
(In reply to comment #4)
> Are there any savefile compatibility issues when upgrading from 0.1.3 to 
0.3.0?

It seems to reset everything.  (Necessarily, I might add, since the levels 
have been rearranged quite a bit.

> If so, then I'd be inclined to avoid upgrading in FC6 and leaving the new
> version in rawhide/FC7 only.

Very good point.
Comment 6 vfiend 2007-02-14 19:09:07 EST
It seems to make a new ~/.supertux2 directory and leave the old ~/.supertux alone.
Comment 7 vfiend 2007-02-17 03:27:49 EST
And your package seems to work fine for me on FC6, thanks. It might make sense
not to push it to FC6 given that it necessitates starting over and isn't
considered completely stable upstream, though.

Note You need to log in before you can comment on or make changes to this bug.