Bug 220679 - system-config-users aborts when freeing invalid pointer
Summary: system-config-users aborts when freeing invalid pointer
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libuser   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-23 00:03 UTC by Jukka Ketelaars
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-06 21:00:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jukka Ketelaars 2006-12-23 00:03:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061027 Firefox/2.0

Description of problem:
When using system-config-users to create a new user the dialog freezes after pressing the ok button. 

When running it from the command line the following error is displayed:
# system-config-users 
*** glibc detected *** /usr/bin/python2: free(): invalid pointer: 0x082560b0 ***


Version-Release number of selected component (if applicable):
system-config-users-1.2.51-1.fc7

How reproducible:
Always


Steps to Reproduce:
1. start system-config-users from command line
2. Press "Add user"
3. User name: test
4. Full name: Test
5. Password/Confirm password: some password
6. Press OK

Actual Results:
The gui freezes and the following error is printed:
*** glibc detected *** /usr/bin/python2: free(): invalid pointer: 0x082560b0 ***

Expected Results:
user should have been created.

Additional info:
glibc-2.5.90-14
python-2.5-6.fc7

Comment 1 Nils Philippsen 2006-12-27 15:50:11 UTC
changing component to python

Comment 2 Jeremy Katz 2007-01-06 21:00:54 UTC
This is being caused by libuser allocating memory with PyObject_Malloc and then
freeing it with PyMem_DEL.  In python 2.5, these actually have a differences (so
that the interpreter can return memory to the system).

Fixed in libuser-0.55-2


Note You need to log in before you can comment on or make changes to this bug.