Bug 220694 - New spec and patch to get pychart building against python 2.5
New spec and patch to get pychart building against python 2.5
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pychart (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-23 05:33 EST by Jef Spaleta
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-18 18:18:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2006-12-23 05:33:18 EST
Here is the srpm that integrates the needed changes to get pychart building
again against python 2.5. I had to add a simple patch to replace optik with
optparse.

http://jspaleta.thecodergeek.com/Fedora%20SRPMS/pychart/pychart-1.39-5.fc7.src.rpm

Additionally the mkhowto in python 2.5 is still not working, so I left the older
patch and Doc tarball in place.  See bug 220693  concerning why mkhowto as
included in current python-tools is busted.

Since this isn't just a bump and build, I wanted to wait for you to take a look
at it. I didn't want to commit this without the maintainers approval.

-jef
Comment 1 Tom "spot" Callaway 2007-01-18 18:18:07 EST
Committed and built.

Note You need to log in before you can comment on or make changes to this bug.