Bug 220699 - firefox get SIGSEGV and refuses to start
firefox get SIGSEGV and refuses to start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-23 11:58 EST by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-21 18:59:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb output from an attempt to start firefox (10.52 KB, text/plain)
2006-12-23 11:58 EST, Michal Jaegermann
no flags Details
Firefox-2.0.0.1-2.fc7 debuginfo backtrace (24.88 KB, text/plain)
2006-12-23 18:36 EST, Jay Cliburn
no flags Details

  None (edit)
Description Michal Jaegermann 2006-12-23 11:58:13 EST
Description of problem:

Firefox updated to firefox-2.0.0.1-2.fc7 opens its window and
immediately bombs out.  When trying to run from a console I am seeing
just this:

GTK Accessibility Module initialized
Segmentation fault

and with 'ulimit' for cores high enough one of 141 Megs in size is
produced.

A backtrace from a run under gdb is attached.  I am running that
on x86_64 machine (although I would be really surprised if that would
turn out architecture specific although accidents in a configuration
may be significant).  Oh, and /usr/libexec/at-spi-registryd is
running so this looks really different from bug 217152.

As I am seeing a similar behaviour from other programs too I start
to wonder if this is not really related to bug 210718 with
fontconfig beeing the real culprit.

Version-Release number of selected component (if applicable):
firefox-2.0.0.1-2.fc7

How reproducible:
every time
Comment 1 Michal Jaegermann 2006-12-23 11:58:13 EST
Created attachment 144331 [details]
gdb output from an attempt to start firefox
Comment 2 Jay Cliburn 2006-12-23 18:36:14 EST
Created attachment 144334 [details]
Firefox-2.0.0.1-2.fc7 debuginfo backtrace
Comment 3 Jay Cliburn 2006-12-23 18:40:00 EST
Comment #2 contains a debuginfo backtrace of a firefox crash on my x86_64
rawhide system, an Asus M2V motherboard running a custom 2.6.20-rc1-current-git
kernel.  The crash is very similar to Michal's.  Similar enough to be considered
a duplicate, I think.
Comment 4 kmberry 2007-01-20 20:59:48 EST
I was forced to erase my fc7 because selinux permissions wouldn't let mkinitrd
make a good image with 2.6.19 rpm.  Everything worked before.  Now since my
fresh install firefox just dumped one day and would only work as root.  Today I
had to report segfault after GTK Accessibility Module initialized on
bittorrent-5.0.5 which started with move to python-2.6 and figured I'd report
this also.  I lost all my bookmarks moving .mozilla back upon itself and have
been using the firefox and thunderbird builds off mozilla.org ever since because
both only work as root whether selinux is off or not.  I thought it was my home
user directory and a botched fc6 update(not enough ram to finish cleanup and
system-config-users wouldn't work) really messed me up and I had to use webmin
to get the right pam modules on the home user directory just to prove it wasn't
my home directory.  Firefox and Thunderbird just don't work as user anymore
permanently.
Comment 5 Michal Jaegermann 2007-01-21 18:59:40 EST
In the current state of rawhide firefox does not exhibit the problem.
It takes a long while to start but it starts without SIGSEGV attractions.

Note You need to log in before you can comment on or make changes to this bug.