Bug 220702 - BUG: warning at kernel/cpu.c:56/unlock_cpu_hotplug()
BUG: warning at kernel/cpu.c:56/unlock_cpu_hotplug()
Status: CLOSED DUPLICATE of bug 214332
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-12-23 12:52 EST by Parag Warudkar
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-26 23:30:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 7442 None None None Never

  None (edit)
Description Parag Warudkar 2006-12-23 12:52:17 EST
Got this in dmesg after a day's uptime. Not sure what triggered it.
SMP kernel running atop a intel Mac Mini.

BUG: warning at kernel/cpu.c:56/unlock_cpu_hotplug() (Not tainted)
 [<c04051db>] dump_trace+0x69/0x1af
 [<c0405339>] show_trace_log_lvl+0x18/0x2c
 [<c04058ed>] show_trace+0xf/0x11
 [<c04059ea>] dump_stack+0x15/0x17
 [<c043c25c>] unlock_cpu_hotplug+0x46/0x6f
 [<df3972a7>] do_dbs_timer+0x127/0x16b [cpufreq_ondemand]
 [<c0433c18>] run_workqueue+0x83/0xc5
 [<c0434508>] worker_thread+0xd9/0x10d
 [<c04369db>] kthread+0xc0/0xed
 [<c0404dab>] kernel_thread_helper+0x7/0x10
DWARF2 unwinder stuck at kernel_thread_helper+0x7/0x10
Leftover inexact backtrace:
Comment 1 Parag Warudkar 2006-12-23 12:54:05 EST
Using latest Fedora 6 kernel.

$ uname -a
Linux paragw 2.6.18-1.2868.fc6 #1 SMP Fri Dec 15 17:32:54 EST 2006 i686 i686 i386 GNU/Linux
Comment 2 Parag Warudkar 2006-12-23 12:59:35 EST
http://bugzilla.kernel.org/show_bug.cgi?id=7442 looks similar.
Comment 3 Parag Warudkar 2006-12-26 23:30:18 EST
Does not seem to happen with vanilla 2.6.20-rc2 on the same machine. (I assume that WARN_ON will 
always warn irrespective of any config changes - my kernel config from 2.6.20-rc2 is different from the 
default Fedora kernel where this error occurs.)
Comment 4 Jarod Wilson 2007-01-02 16:23:56 EST

*** This bug has been marked as a duplicate of 214332 ***

Note You need to log in before you can comment on or make changes to this bug.