Bug 220721 - rssowl does not start on x86_64
rssowl does not start on x86_64
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rssowl (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-24 08:27 EST by Robin Green
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-22 10:59:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2006-12-24 08:27:17 EST
Description of problem:
rssowl does not start on x86_64 due to a buglet in /usr/bin/rssowl

Version-Release number of selected component (if applicable):
rssowl-1.2.3-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. rssowl
  
Actual results:
Exception in thread "main" java.lang.NoClassDefFoundError:
net.sourceforge.rssowl.controller.RSSOwlLoader
   at java.lang.Class.initializeClass(libgcj.so.7rh)
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Shell not
found in
gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/share/java/rssowl.jar,file:/usr/share/java/xerces-j2.jar,file:/usr/share/java/itext.jar,file:/usr/share/eclipse/plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar,file:/usr/share/eclipse/plugins/org.eclipse.core.commands_3.2.0.I20060605-1400.jar,file:/usr/share/java/commons-logging.jar,file:/usr/share/eclipse/plugins/org.eclipse.jface_3.2.1.M20060908-1000.jar,file:/usr/share/eclipse/plugins/org.eclipse.equinox.common_3.2.0.v20060603.jar,file:/usr/share/java/jdom.jar,file:/usr/share/java/commons-httpclient.jar,file:/usr/share/java/commons-codec.jar,file:/usr/share/java/glib0.2.jar,file:/usr/share/java/gconf2.12.jar,file:/usr/share/java/gtk2.8.jar,file:/usr/share/java/],
parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at java.net.URLClassLoader.findClass(libgcj.so.7rh)
   at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
   at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
   at java.lang.Class.initializeClass(libgcj.so.7rh)


Expected results:
rssowl should start

Additional info:
/usr/lib/eclipse/swt-gtk-3.2.jar in the classpath should have /usr/lib64/
instead of /usr/lib. See below.

--- /usr/bin/rssowl.orig        2006-12-24 13:21:46.000000000 +0000
+++ /usr/bin/rssowl     2006-12-24 13:22:03.000000000 +0000
@@ -10,7 +10,7 @@
 fi
 export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$MOZILLA_FIVE_HOME

-exec java -Djava.library.path=/usr/lib64/ -cp
/usr/share/java/rssowl.jar:/usr/share/java/xerces-j2.jar:/usr/share/java/itext.jar:/usr/share/eclipse/plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar:/usr/share/eclipse/plugins/org.eclipse.core.commands_3.2.0.I20060605-1400.jar:/usr/lib/eclipse/swt-gtk-3.2.jar:/usr/share/java/commons-logging.jar:/usr/share/eclipse/plugins/org.eclipse.jface_3.2.1.M20060908-1000.jar:/usr/lib/eclipse/plugins/com.ibm.icu_3.4.5.jar:/usr/share/eclipse/plugins/org.eclipse.equinox.common_3.2.0.v20060603.jar:/usr/share/java/jdom.jar:/usr/share/java/commons-httpclient.jar:/usr/share/java/commons-codec.jar:/usr/share/java/glib0.2.jar:/usr/share/java/gconf2.12.jar:/usr/share/java/gtk2.8.jar:/usr/share/java/
net.sourceforge.rssowl.controller.RSSOwlLoader "$@"
+exec java -Djava.library.path=/usr/lib64/ -cp
/usr/share/java/rssowl.jar:/usr/share/java/xerces-j2.jar:/usr/share/java/itext.jar:/usr/share/eclipse/plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar:/usr/share/eclipse/plugins/org.eclipse.core.commands_3.2.0.I20060605-1400.jar:/usr/lib64/eclipse/swt-gtk-3.2.jar:/usr/share/java/commons-logging.jar:/usr/share/eclipse/plugins/org.eclipse.jface_3.2.1.M20060908-1000.jar:/usr/lib/eclipse/plugins/com.ibm.icu_3.4.5.jar:/usr/share/eclipse/plugins/org.eclipse.equinox.common_3.2.0.v20060603.jar:/usr/share/java/jdom.jar:/usr/share/java/commons-httpclient.jar:/usr/share/java/commons-codec.jar:/usr/share/java/glib0.2.jar:/usr/share/java/gconf2.12.jar:/usr/share/java/gtk2.8.jar:/usr/share/java/
net.sourceforge.rssowl.controller.RSSOwlLoader "$@"
Comment 1 Anthony Green 2007-01-07 00:55:21 EST
What about /usr/lib/eclipse/plugins/com.ibm.icu_3.4.5.jar?  Should that be lib64
as well?  I don't have an x86-64 system to check on.

Comment 2 Andrew Overholt 2007-01-07 10:33:44 EST
(In reply to comment #1)
> What about /usr/lib/eclipse/plugins/com.ibm.icu_3.4.5.jar?  Should that be lib64
> as well?  I don't have an x86-64 system to check on.

Yeah.
Comment 3 Anthony Green 2007-03-06 11:42:06 EST
I believe this was fixed in 1.2.3-3.
Comment 4 Robin Green 2007-04-05 10:14:09 EDT
No, it wasn't.

$ rpm -q rssowl
rssowl-1.2.3-3.fc7
Comment 5 Rick Sewill 2007-06-17 19:44:46 EDT
I have this problem also.  
$ rpm -q rssowl
rssowl-1.2.3-3.fc7.x86_64

Since /usr/lib/eclipse does not exist, and until this problem is fixed, 
I have done:

cd /usr/lib ; ln -s /usr/lib64/eclipse

This seems to work for me...I believe this is a workaround, not a solution.
Comment 6 Andrew Overholt 2007-06-18 11:48:19 EDT
This isn't working:

sed --in-place "s:/usr/lib:%{_libdir}:" \
  $RPM_BUILD_ROOT%{_bindir}/%{name}

because it needs a trailing g.  I've fixed, am building now, and will push an
update.  Sorry about that.
Comment 7 Andrew Overholt 2007-06-18 13:15:56 EDT
My build finished and I submitted to updates-testing.  It should be available
soon and at that point you can:

yum --enablerepo=updates-testing update rssowl

to test if the fix worked.  If it does, please let me know and I can push the
update to final.
Comment 8 Fedora Update System 2007-06-18 18:28:35 EDT
rssowl-1.2.3-4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Anthony Green 2007-06-22 10:59:52 EDT
rssowl was just removed due to the loss of itext.  My understanding is that
rssowl2 doesn't depend on itext, and we intend to re-introduce rssowl2 when
rawhide gets a newer SWT.  I'm closing this bug for now.

Note You need to log in before you can comment on or make changes to this bug.