Bug 220754 - Error when trying to install Wine via yum
Error when trying to install Wine via yum
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: db4 (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-25 16:15 EST by Jernej
Modified: 2013-07-02 19:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 02:08:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jernej 2006-12-25 16:15:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.root login
2.yum install wine
3.error

Actual Results:
Loading "installonlyn" plugin
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbenv->open: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 -  (-30977)
error: cannot open Packages database in /var/lib/rpm
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 85, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 199, in getOptionsConfig
    errorlevel=opts.errorlevel)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 125, in doConfigSetup
    self.conf = config.readMainConfig(startupconf)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 597, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 656, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed

Expected Results:
wine should install

Additional info:
Component: Software Manager
Summary: TBc3704fb6 config.py:656:_getsysver:TypeError: rpmdb open failed

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 453, in ?
    main()
  File "/usr/sbin/pirut", line 446, in main
    pm = PackageManager(options.config)
  File "/usr/sbin/pirut", line 60, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 124, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 125, in doConfigSetup
    self.conf = config.readMainConfig(startupconf)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 597, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 656, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed

Local variables in innermost frame:
installroot: /
ts: <rpmUtils.transaction.TransactionWrapper instance at 0x8f4e7ac>
distroverpkg: redhat-release
Comment 1 Jernej 2006-12-25 16:19:48 EST
On http://www.winehq.com/site/download it is said " 	Red Hat / Fedora binary and
source .rpms for RedHat 8, 9; Fedora Core 3, 4, 5; and compatible distributions.
The wine meta package is available via yum through the Fedora Extras repository
by running $ yum install wine ""

Well, as we see, sth is wrong...
Comment 2 Jindrich Novy 2007-01-03 04:19:54 EST
Maybe it is related to:

http://kerneltrap.org/node/7518
(please look for "db4" in comments to the article)

what seems to be a kernel issue which has recently been fixed by Linus.

Dave, since I'm not a kernel guy, could you please confirm the db4 database
corruption could be caused by this and whether it is planned to be fixed in the
2.6.19 release?

Thanks.
Comment 3 Dave Jones 2007-01-07 23:59:39 EST
somewhat unlikely.  There have been no definitive reports that this problem is
related to any misbehaviour in db4, just lots of 'maybe'.

There's a 2.6.19.2 based kernel that will be in testing soon, which has the fix
anyway. (Preview at http://people.redhat.com/davej/kernels/Fedora/FC6)
Comment 4 Jindrich Novy 2007-01-22 07:06:08 EST
The 2.6.19 kernels are now out even for FC6, do you still see any breakage?
Comment 5 Jernej 2007-01-24 16:21:48 EST
(In reply to comment #4)
> The 2.6.19 kernels are now out even for FC6, do you still see any breakage?

After few reboots (running the same kernel) I tried the same thing and it 
worked.

This kind of behaviour I`m used in Windows, didn`t expect that kind of magic in 
Linux...

Comment 6 Jindrich Novy 2007-01-25 02:08:02 EST
Ok, closing NOTABUG for now then.

Feel free to reopen if you see the same thing again.

Note You need to log in before you can comment on or make changes to this bug.