Bug 220773 - new iPod nano not autmounted due to being recognized as via-raid-member
new iPod nano not autmounted due to being recognized as via-raid-member
Status: CLOSED DUPLICATE of bug 220543
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
https://launchpad.net/distros/ubuntu/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-26 10:03 EST by Giray Devlet
Modified: 2013-03-05 22:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 15:54:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 9311 None None None Never

  None (edit)
Description Giray Devlet 2006-12-26 10:03:24 EST
Due to Apple's interesting way of initializing the storage on their new iPod
Nano series, the vfat partition is detected as a Via RAID volume, which clearly
is not right.. This in turn means that nothing happens when plugging it in,
since gnome-volume-manager won't touch raid members.

lshal output


udi = '/org/freedesktop/Hal/devices/volume_part2_size_3948134400'
  volume.policy.should_mount = true  (bool)
  volume.policy.mount_option.sync = true  (bool)
  volume.policy.desired_mount_point = 'ipod'  (string)
  info.udi = '/org/freedesktop/Hal/devices/volume_part2_size_3948134400'  (string)
  volume.partition.msdos_part_table_type = 11  (0xb)  (int)
  info.product = 'Volume (via_raid_member)'  (string)
  volume.size = 3948134400  (0xeb53c000)  (uint64)
  volume.num_blocks = 7711200  (0x75a9e0)  (int)
  volume.block_size = 2048  (0x800)  (int)
  volume.partition.number = 2  (0x2)  (int)
  info.capabilities = {'volume', 'block'} (string list)
  info.category = 'volume'  (string)
  volume.is_partition = true  (bool)
  volume.is_disc = false  (bool)
  volume.is_mounted = false  (bool)
  volume.mount_point = ''  (string)
  volume.label = ''  (string)
  volume.uuid = ''  (string)
  volume.fsversion = '0'  (string)
  volume.fsusage = 'raid'  (string)
  volume.fstype = 'via_raid_member'  (string)
  storage.model = ''  (string)
  block.storage_device =
'/org/freedesktop/Hal/devices/storage_serial_Apple_iPod_000A270018FC5587'  (string)
  block.is_volume = true  (bool)
  block.minor = 2  (0x2)  (int)
  block.major = 8  (0x8)  (int)
  block.device = '/dev/sda2'  (string)
  linux.hotplug_type = 3  (0x3)  (int)
  info.parent =
'/org/freedesktop/Hal/devices/storage_serial_Apple_iPod_000A270018FC5587'  (string)
  linux.sysfs_path_device = '/sys/block/sda/sda2'  (string)
  linux.sysfs_path = '/sys/block/sda/sda2'  (string)
Comment 1 David Zeuthen 2007-01-02 15:54:08 EST

*** This bug has been marked as a duplicate of 220543 ***

Note You need to log in before you can comment on or make changes to this bug.