Bug 220791 - Conflict between i386 and x86_64 devel packages
Conflict between i386 and x86_64 devel packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-26 20:52 EST by Adam Huffman
Modified: 2013-03-05 22:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-04 07:19:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2006-12-26 20:52:07 EST
Description of problem:
I have just tried to install the x86_64 version of the hal-devel package, but it
failed at the transaction test stage because of a file conflict between the i386
and x86_64 versions:

Transaction Check Error:   file /usr/share/gtk-doc/html/hal/ch01.html from
install of hal-devel-0.5.8.1-5.fc6 conflicts with file from package
hal-devel-0.5.8.1-5.fc6
  file /usr/share/gtk-doc/html/hal/ch02.html from install of
hal-devel-0.5.8.1-5.fc6 conflicts with file from package hal-devel-0.5.8.1-5.fc6
  file /usr/share/gtk-doc/html/hal/hal-libhal-storage.html from install of
hal-devel-0.5.8.1-5.fc6 conflicts with file from package hal-devel-0.5.8.1-5.fc6
  file /usr/share/gtk-doc/html/hal/hal-libhal.html from install of
hal-devel-0.5.8.1-5.fc6 conflicts with file from package hal-devel-0.5.8.1-5.fc6


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Underhill 2007-04-03 15:02:58 EDT
I'm seeing a similar problem on my x86_64 FC7 Test 3 box. 

rpm -q --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" hal

returns 

hal-0.5.9-0.git20070401.1.fc7.i386
hal-0.5.9-0.git20070401.1.fc7.x86_64

yum update tries to update the x86_64 version alone to 0.5.9-1.fc7 and the
update fails with:
Transaction Check Error:
  file /usr/share/man/man1/hal-disable-polling.1.gz from install of
hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7
  file /usr/share/man/man1/hal-find-by-capability.1.gz from install of
hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7
  file /usr/share/man/man1/hal-find-by-property.1.gz from install of
hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7
  file /usr/share/man/man1/hal-get-property.1.gz from install of hal-0.5.9-1.fc7
conflicts with file from package hal-0.5.9-0.git20070401.1.fc7
  file /usr/share/man/man1/hal-is-caller-locked-out.1.gz from install of
hal-0.5.9-1.fc7 conflicts with file from package hal-0.5.9-0.git20070401.1.fc7
  file /usr/share/man/man1/hal-lock.1.gz from install of hal-0.5.9-1.fc7
conflicts with file from package hal-0.5.9-0.git20070401.1.fc7
  file /usr/share/man/man1/hal-set-property.1.gz from install of hal-0.5.9-1.fc7
conflicts with file from package hal-0.5.9-0.git20070401.1.fc7
  file /usr/share/man/man1/lshal.1.gz from install of hal-0.5.9-1.fc7 conflicts
with file from package hal-0.5.9-0.git20070401.1.fc7

Comment 2 Chris Underhill 2007-04-05 14:22:59 EDT
The dependency problem I mentioned is also covered in bugs 235128 and 235152.
Comment 3 Bug Zapper 2008-04-04 01:22:08 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Huffman 2008-04-23 12:01:48 EDT
I can't reproduce this anymore.
Comment 5 Peter van Egdom 2008-05-04 07:19:14 EDT
Thank you for the bug report. Closing bug as per comment #4.

Note You need to log in before you can comment on or make changes to this bug.