Bug 220799 - multiple master map entries with the same key are handled improperly
multiple master map entries with the same key are handled improperly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
: Regression
Depends On: 218616
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-26 23:18 EST by Ian Kent
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 21:03:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Correct detection of duplicate indirect mount entries. (636 bytes, patch)
2006-12-26 23:18 EST, Ian Kent
no flags Details | Diff

  None (edit)
Comment 1 Ian Kent 2006-12-26 23:18:26 EST
Created attachment 144384 [details]
Correct detection of duplicate indirect mount entries.
Comment 2 Ian Kent 2006-12-26 23:21:12 EST
Testing has identified that the patch for bug 218616
introduced a regression with map reloading.

The above patch resolves this.
Comment 3 RHEL Product and Program Management 2006-12-26 23:24:59 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 4 Ian Kent 2006-12-27 00:03:31 EST
(In reply to comment #3)
> This bugzilla has Keywords: Regression.  
> 
> Since no regressions are allowed between releases, 
> it is also being proposed as a blocker for this release.  
> 
> Please resolve ASAP.

The patch "Correct detection of duplicate indirect mount
entries" resolves this issue.

It has been added to cvs and is present in
autofs-5.0.1-0.rc2.39.

Ian
Comment 6 RHEL Product and Program Management 2007-02-07 21:03:23 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.