This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 220856 - csound currently fails to build
csound currently fails to build
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: csound (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-27 20:47 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-07 23:13:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
csound spec file diff (5.42 KB, text/x-patch)
2006-12-27 20:47 EST, Paul F. Johnson
no flags Details
patch for rtalsa (305 bytes, patch)
2006-12-27 20:49 EST, Paul F. Johnson
no flags Details | Diff

  None (edit)
Description Paul F. Johnson 2006-12-27 20:47:34 EST
Description of problem:
csound is currently not building in rawhide. I've amended the spec file
(attached to this BZ) which addresses quite a lot of problems. However, it looks
like fluid is shot as it's generating code out of scope (it could be the source
itself, I don't know fluid enough to say).

The diff attached addresses BZ 210215 as well

Version-Release number of selected component (if applicable):
5.03

How reproducible:
Always

Steps to Reproduce:
1. Apply the diff and new patch to the current spec, grab the new sources
2. Build
  
Actual results:
Build fails at CsoundGUIConsole_FLTK.cpp - o is out of scope

Expected results:
Build works

Additional info:
I'm now down as the co-maintainer for this package
Comment 1 Paul F. Johnson 2006-12-27 20:47:34 EST
Created attachment 144433 [details]
csound spec file diff
Comment 2 Paul F. Johnson 2006-12-27 20:49:11 EST
Created attachment 144434 [details]
patch for rtalsa

This fixes a problem with alsa.h that redefines a couple of time functions if
POSIX_C_SOURCE is not defined
Comment 3 Paul F. Johnson 2006-12-28 20:28:28 EST
fltk problem BZ : 220933

fltk has been rebuilt with a newer snapshot, but still produces broken C++
Comment 4 Kevin Fenzi 2007-02-28 11:17:01 EST
I'm still seeing this in current rawhide. 

From the builds: 

> Doing a build here from the cvs checkout, I get: 
> 
> (on x86_64): 
> g++ -fexceptions -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
> -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64
> -mtune=generic -Wall -g -O2 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
> -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64
> -mtune=generic -fPIC -DLINUX -DPIPES -DNO_FLTK_THREADS -O2 -g -pipe
> -Wall -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32
> -march=i386 -mtune=generic -fasynchronous-unwind-tables -O2 -g -pipe
> -Wall -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32
> -march=i386 -mtune=generic -fasynchronous-unwind-tables -fPIC
> -DHAVE_LIBSNDFILE=1016 -DHAVE_FLTK -DBETA -DHAVE_FCNTL_H
> -DHAVE_UNISTD_H -DHAVE_STDINT_H -DHAVE_SYS_TIME_H -DHAVE_SYS_TYPES_H
> -DHAVE_TERMIOS_H -DHAVE_SOCKETS -DHAVE_DIRENT_H -Wp,-D_FORTIFY_SOURCE=2
> -Wp,-D_FORTIFY_SOURCE=2 -I. -IH -I/usr/include -I/usr/X11R6/include
> -I/usr/include/freetype2 -IInOut -IInOut/virtual_keyboard -c -o
> InOut/FL_graph.os InOut/FL_graph.cpp In file included
> from /usr/include/features.h:352, from /usr/include/stdio.h:28, from
> H/sysdep.h:52, from H/csoundCore.h:31, from H/csdl.h:35, from
> InOut/FL_graph.cpp:33: /usr/include/gnu/stubs.h:7:27: error:
> gnu/stubs-32.h: No such file or directory scons: ***
> [InOut/FL_graph.os] Error 1 scons: building terminated because of
> errors.
> 
> 
> (on i386):
> 
> gcc -Wall -g -O2 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
> -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32
> -march=i386 -mtune=generic -fasynchronous-unwind-tables -DLINUX -DPIPES
> -fPIC -DHAVE_LIBSNDFILE=1016 -DHAVE_FLTK -DBETA -DHAVE_FCNTL_H
> -DHAVE_UNISTD_H -DHAVE_STDINT_H -DHAVE_SYS_TIME_H -DHAVE_SYS_TYPES_H
> -DHAVE_TERMIOS_H -DHAVE_SOCKETS -DHAVE_DIRENT_H -I. -IH -I/usr/include
> -I/usr/X11R6/include -c -o InOut/rtalsa.os InOut/rtalsa.c In file
> included from /usr/include/alsa/asoundlib.h:44, from
> InOut/rtalsa.c:44: /usr/include/alsa/global.h:134: error: redefinition
> of 'struct timeval' /usr/include/alsa/global.h:139: error: redefinition
> of 'struct timespec' scons: *** [InOut/rtalsa.os] Error 1 scons:
> building terminated because of errors. error: Bad exit status
> from /var/tmp/rpm-tmp.51608 (%build)

Would be good to get this fixed so the csound broken dependencies in the repo
are solved. 

Also, 5.04 is out, but from a quick test it didn't seem to have any effect on
the above build failures... 
Comment 5 Dan Williams 2007-03-07 23:13:40 EST
rebuilt for devel but not csound 5.04 quite yet...  it seems they make you do
cvs checkouts to get everything, I also couldn't find a CVS tag for 5.04.2, just
5.04.

Note You need to log in before you can comment on or make changes to this bug.