Bug 220870 - Problem accessing internet
Problem accessing internet
Status: CLOSED DUPLICATE of bug 196715
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-12-28 01:05 EST by Nick Andrews
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-03 01:56:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nick Andrews 2006-12-28 01:05:18 EST
Description of problem:

Clean install of fedora core 6 -> cannot access a high proportion of websites 
or ftp sites (and likely other internet services).

webbrowsers sit doing nothing after requesting a page, Yum gets no further 
than "Setting up repositories" - then does nothing.  Similar results from FTP 

www.google.co.uk comes up fine in a browser but no redhat sites work.   DNS 
resolution works as expected.

Tried disabling ipv6, and checksum offloading to no avail.

Works flawlessly using the same configuration on FC5.

manually built a kernel using oldconfig with the same results ...

Have resinstalled FC6 completely 3 times with no change.

asus a7m-266d, 2x AMD MP 2000+ CPUs, 1Gig RAM
tried with both 3com 3c905C and netgear FA311 NICs

Version-Release number of selected component (if applicable):

Fedora core 6 (zod) ISO
also tested with kernel compile using oldconfig - same problem.
also affects XEN kernels.
Comment 1 Nick Andrews 2006-12-28 01:15:56 EST
The machine sits behind an ADSL router (U.S.Robotics SureConnect) however this 
same setup works fine from FC5, WinXP, WinXP64, Win Vista 64 and Win2k3 server.
Comment 2 Nick Andrews 2006-12-28 11:09:54 EST
Found reference to a problem on the suse mailing list that sounds identical - 
using the same kernel
Comment 3 Nick Andrews 2006-12-28 11:10:25 EST
Found reference to a problem on the suse mailing list that sounds identical - 
using the same kernel http://www.mail-
Comment 4 Jarod Wilson 2007-01-02 16:19:05 EST
Does FC6 work as expected after you do this (as root):

# echo 0 > /proc/sys/net/ipv4/tcp_window_scaling


(See bug 196715 for additional data)
Comment 5 Nick Andrews 2007-01-03 01:50:24 EST
Yes! thanks a million for your help =D
Comment 6 Jarod Wilson 2007-01-04 10:16:48 EST

*** This bug has been marked as a duplicate of 196715 ***

Note You need to log in before you can comment on or make changes to this bug.