Bug 220975 - Unable to recompile .src.rpm
Unable to recompile .src.rpm
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-29 15:50 EST by Adam Huffman
Modified: 2008-02-11 22:21 EST (History)
0 users

See Also:
Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 22:21:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2006-12-29 15:50:38 EST
Description of problem:

I have been trying to recompile NM in order to try out a patch which might fix a
network connection problem.  There seems to be a problem with the checks at the
start of the spec file:

rpmbuild -ba NetworkManager.spec
error: parse error in expression
error: /home/adam/rpmbuild/SPECS/NetworkManager.spec:15: parseExpressionBoolean
returns -1
error: Name field must be present in package: (main package)
error: Version field must be present in package: (main package)
error: Release field must be present in package: (main package)
error: Summary field must be present in package: (main package)
error: Group field must be present in package: (main package)
error: License field must be present in package: (main package)

Version-Release number of selected component (if applicable):
0.6.4-5.fc6

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:
.src.rpm should install normally

Expected results:


Additional info:
Comment 1 Denis Leroy 2007-03-26 10:37:48 EDT
It will compile if you add --define 'fedora 6'

but it will fail later on this error:

NetworkManagerDbus.c: In function 'nm_dbus_init':
NetworkManagerDbus.c:837: error: 'DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT'
undeclared (first use in this function)


I'm concerned that no updates to NetworkManager were ever pushed for FC-6 even
though the FC-6 branch in CVS seems to contain a number of useful patches. There
were FC-6 updates from dbus 0.93 to dbus 1.0.1, but NM didn't catch up.

How can I help ?
Comment 2 Dan Williams 2008-02-11 22:21:09 EST
Should be fixed in F7 and later at least, that RPM should also work on FC6.

Note You need to log in before you can comment on or make changes to this bug.