Bug 220984 - Kernel hang on Supermicro P4SCT with sata_mv
Kernel hang on Supermicro P4SCT with sata_mv
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-29 17:41 EST by Milan Kerslager
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 16:47:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (kernel-2.6.18-1.2913.2.1.el5.gtest.3) (26.79 KB, text/plain)
2006-12-29 17:47 EST, Milan Kerslager
no flags Details
lsmod (1.88 KB, text/plain)
2006-12-29 17:47 EST, Milan Kerslager
no flags Details
lspci (1.30 KB, text/plain)
2006-12-29 17:48 EST, Milan Kerslager
no flags Details

  None (edit)
Description Milan Kerslager 2006-12-29 17:41:20 EST
This is Supermicro P4SCT+ rev. 1.11 with latest BIOS update (1.2b, 06/12/2006).

The system has been reported to me as stable with FC3 in the past. Now with
RHEL4 or RHEL5b2 I see random hard hangs (after minutes to several hours of
uptime). There are 7 discs (SATA WD4000KD-00N) connected to the MV88SX5081
8-port SATA I PCI-X Controller. I tryed binary kernel module instead of sata_mv
too with no luck (there is RAID5 array but with no dmraid now).

I tryed to disable hyperthreading, update BIOS, boot with noapic kernel
parameter with no luck. The system hanged during startup sequence on hotplud and
smartd daemon start so I disabled these. Other hangs was after some time with no
traces or OOPSes in the logs or on the screen.

I still have no clue about what going on (maybe SATA driver/card?). I moved the
system to my home to be able to do more testing so please ask me for what I have
to try.

The system is now running the latest test kernel (2.6.18-1.2913.2.1.el5.gtest.3)
for RHEL5 from http://people.redhat.com/agospoda/rhel5/gtest/.
Comment 1 Milan Kerslager 2006-12-29 17:47:17 EST
Created attachment 144565 [details]
dmesg output (kernel-2.6.18-1.2913.2.1.el5.gtest.3)
Comment 2 Milan Kerslager 2006-12-29 17:47:54 EST
Created attachment 144566 [details]
lsmod
Comment 3 Milan Kerslager 2006-12-29 17:48:24 EST
Created attachment 144567 [details]
lspci
Comment 4 Milan Kerslager 2007-01-10 03:28:44 EST
I'm using kernel 2.6.18-1.2962.2.1.el5.gtest.4.i686 (HT off) from
http://people.redhat.com/agospoda/#rhel5 and the system seems to be stable last
few days (it survives rebuilding RAID5 arrays). Also I put off console blanking
by "setterm -blank 0 > /dev/tty[1-8]".

I'm going to do some stress tests to make sure it will not hang again.
Comment 5 Milan Kerslager 2007-03-20 18:41:58 EDT
It seems like HW bug on motherboard (the last piece of HW that has been claimed).
I'm not able to close bug as NOTABUG even I'm a submiter. Please close. Thank you.
Comment 6 Ernie Petrides 2007-09-05 16:47:30 EDT
Closing at the request of reporter.

Note You need to log in before you can comment on or make changes to this bug.