Bug 221046 - aisleriot crashes on exit, launching bug-buddy
aisleriot crashes on exit, launching bug-buddy
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: at-spi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-30 22:06 EST by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-01 22:33:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no debuginfo version (6.49 KB, text/plain)
2006-12-30 22:06 EST, Jim Cornette
no flags Details
Crash after winning game with debugino installed (5.24 KB, text/plain)
2006-12-31 10:36 EST, Jim Cornette
no flags Details
Added ORBit2-debuginfo for more details (7.66 KB, text/plain)
2006-12-31 18:27 EST, Jim Cornette
no flags Details
Added more debuginfo rpms for missing symbols (9.25 KB, text/plain)
2006-12-31 22:25 EST, Jim Cornette
no flags Details
With latest updates - debuginfo updated (9.28 KB, text/plain)
2007-01-05 16:42 EST, Jim Cornette
no flags Details
After development update crash is still happening. (9.28 KB, text/plain)
2007-01-06 10:34 EST, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2006-12-30 22:06:48 EST
Description of problem:
I played the game, won the game and got a crash and bug-buddy generated report
on exit. I did not have the debuginfo packages so this report has no symbols. I
installed the debuginfo packages for gnome-games now so future reports will be
more useful.

Version-Release number of selected component (if applicable):
gnome-games-i386 1:2.17.4.1-2.fc7

How reproducible:
Play the game, then exit after you win for answering play another game or exit.

Steps to Reproduce:
1. match cards
2. win game
3. decide to quit instead of playing another game
  
Actual results:

Bug buddy launches and a report is saved to relay information. No debuginfo on
this report which is attached.

Expected results:

A large amount of money added to my bank account for winning the game.

Additional info:
Comment 1 Jim Cornette 2006-12-30 22:06:49 EST
Created attachment 144589 [details]
no debuginfo version
Comment 2 Jim Cornette 2006-12-31 10:36:43 EST
Created attachment 144592 [details]
Crash after winning game with debugino installed

This error was generated by bugbuddy and sol was won and quit was chosen
instead of new game at dialog box.
Comment 3 Jim Cornette 2006-12-31 15:56:27 EST
Upstream bug report filed as below:
http://bugzilla.gnome.org/show_bug.cgi?id=391331
Comment 4 Jim Cornette 2006-12-31 18:27:31 EST
Created attachment 144597 [details]
Added ORBit2-debuginfo for more details

After playing again and winning. quiting the program dumped more info with
ORBit2-debuginfo installed.
Comment 5 Jim Cornette 2006-12-31 22:25:31 EST
Created attachment 144601 [details]
Added more debuginfo rpms for missing symbols

Debugging packages installed.

at-spi-debuginfo-1.7.14-1.fc7.i386.rpm
glibc-debuginfo-2.5.90-14.i686.rpm
glibc-debuginfo-common-2.5.90-14.i386.rpm
gnome-games-debuginfo-2.17.4.1-2.fc7.i386.rpm
guile-debuginfo-1.8.1-1.fc7.i386.rpm
kernel-debuginfo-2.6.19-1.2891.fc7.i686.rpm
kernel-debuginfo-common-2.6.19-1.2891.fc7.i686.rpm
libgnomeui-debuginfo-2.17.0-1.fc7.i386.rpm
ORBit2-debuginfo-2.14.4-1.fc7.i386.rpm
Comment 6 Jim Cornette 2007-01-05 16:36:21 EST
Changing component which causes problem to guile since upstream diagnosis points
to component.
Comment 7 Jim Cornette 2007-01-05 16:39:57 EST
Adding mlichvar@redhat.com to CC: since listed as repsonsible for guile.
Comment 8 Jim Cornette 2007-01-05 16:42:23 EST
Created attachment 144935 [details]
With latest updates - debuginfo updated

It seems to crash as before the updates were applied. Here is the most current
debuginfo.
Comment 9 Jim Cornette 2007-01-06 10:34:49 EST
Created attachment 144973 [details]
After development update crash is still happening.

I was hoping that one of the last updated packages would resolve this error.
The error still happens after an install and system reboot to be sure no stale
references to libraries.

Debug packages installed:
gnome-games-debuginfo-2.17.4.1-2.fc7
guile-debuginfo-1.8.1-1.fc7
glibc-debuginfo-common-2.5.90-14
libgnomeui-debuginfo-2.17.0-1.fc7
kernel-debuginfo-common-2.6.19-1.2904.fc7
ORBit2-debuginfo-2.14.4-1.fc7
at-spi-debuginfo-1.7.14-1.fc7
kernel-debuginfo-2.6.19-1.2904.fc7
glibc-debuginfo-2.5.90-14
Comment 10 Jim Cornette 2007-01-08 18:11:30 EST
After posting on the test list, the common component seems to be ORBit2 for many
crashing on exit application problems. Adding mclasen@redhat.com to the CC and
changing suspected component to ORBit2.
Comment 11 Jim Cornette 2007-01-10 21:38:55 EST
downgrading to at-spi stops the crashing on quiting applications. Changing
component to at-spi.

version that crash does not happen is at-spi-1.7.11-2.fc6
Comment 12 Derek Atkins 2007-01-18 09:09:33 EST
MANY gnome applications crash on exit with GNOME Acccessibility turned on.  I
suspect that this upstream bug in at-spi is applicable: 
http://bugzilla.gnome.org/show_bug.cgi?id=364839

This problem happens in both FC5 and FC6.  I'm told it's been fixed in
at-spi-1.7.15-1.fc7 but that doesn't help FC5 and FC6 people.
Comment 13 Jim Cornette 2007-01-31 18:15:47 EST
at-spi in development works fine for me. As far as winnig the gam and choosing
quit, i do not recall a crashing problem with FC6. at-spi domino effect with
ORBit2 seems to be the problem with the development problem.

somehow my mail from bug reports does not arrive. I need to investigate why.
Sorry for the lag in response.

I wil retest in FC6 to see if the game crashes as did the game in development
before atr-spi was fixed.
Comment 14 Jim Cornette 2007-02-01 22:33:57 EST
Testing in FC6 does not have klondike crash on quit as earlier happened with
development. I have at-spi-1.7.11-2.fc6 installed. I guess this bug can be
closed. It was fixed in rawhide by at-spi and I never experienced the problem
with FC6.

Note You need to log in before you can comment on or make changes to this bug.