Bug 221049 - glibc-devel package contains broken links
glibc-devel package contains broken links
Status: CLOSED DUPLICATE of bug 213555
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-31 03:49 EST by Christian Krause
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 17:44:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Krause 2006-12-31 03:49:55 EST
Description of problem:
glibc-devel contains a symbolic link
/usr/lib/librt.so.1 -> librtkaio.so
which points to a non-existing file

Version-Release number of selected component (if applicable):
glibc-devel-2.5-3.i386.rpm

How reproducible:
100%

Steps to Reproduce:

root@computer:/etc# rpm -U /fedora-core/6/i386/os/Fedora/RPMS/glibc-2.5-3.i686.rpm
 /fedora-core/6/i386/os/Fedora/RPMS/glibc-devel-2.5-3.i386.rpm --force

root@computer:/etc# rpm -V glibc glibc-devel

root@computer:/etc# ls -la /usr/lib/librt*
-rw-r--r-- 1 root root 52128 Oct  8 17:10 /usr/lib/librt.a
-rw-r--r-- 1 root root 59038 Oct  8 17:10 /usr/lib/librtkaio.a
lrwxrwxrwx 1 root root    20 Dec 31 09:42 /usr/lib/librt.so -> ../../lib/librt.s
o.1
lrwxrwxrwx 1 root root    12 Dec 31 09:42 /usr/lib/librt.so.1 -> librtkaio.so

root@computer:/etc# /sbin/ldconfig 

root@computer:/etc# ls -la /usr/lib/librt*
-rw-r--r-- 1 root root 52128 Oct  8 17:10 /usr/lib/librt.a
-rw-r--r-- 1 root root 59038 Oct  8 17:10 /usr/lib/librtkaio.a
lrwxrwxrwx 1 root root    20 Dec 31 09:42 /usr/lib/librt.so -> ../../lib/librt.s
o.1

root@computer:/etc# rpm -V glibc glibc-devel
missing     /usr/lib/librt.so.1

Actual results:
before ldconfig call:
- librt.so.1 is a broken link
after ldconfig call
- librt.so.1 is missing (deleted by ldconfig)

Expected results:
glibc-devel should contain the correct symbolic link and after ldconfig the
glibc-devel package should be consistent with the file system (rpm -V glibc-devel)
Comment 1 Jakub Jelinek 2007-01-02 17:44:51 EST

*** This bug has been marked as a duplicate of 213555 ***

Note You need to log in before you can comment on or make changes to this bug.