Bug 221050 - mighty mouse does not scroll horizontally
mighty mouse does not scroll horizontally
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-31 05:21 EST by Vladimir Kotal
Modified: 2008-06-21 10:56 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.20-1.2933.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 17:34:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Kotal 2006-12-31 05:21:51 EST
Description of problem:
Apple mighty mouse (USB version) does not scroll horizontally.

Version-Release number of selected component (if applicable):
[katka@erazim ~]$ rpm -q kernel
kernel-2.6.18-1.2849.fc6
kernel-2.6.18-1.2868.fc6

How reproducible:
scrolling the middle "button"

Actual results:
nothing happens

Expected results:
should scroll horizontally.

Additional info:
There seems to be a solution in form of a kernel patch for this problem:
http://fob.po8.org/node/165

I am filing this bug to keep track of fixing this in Fedora Core.
Comment 1 Chuck Ebbert 2007-05-16 17:34:54 EDT
Patch is in kernel 2.6.20 -- closing bug.
Comment 2 Vladimir Kotal 2008-06-21 10:56:32 EDT
Wow, it works now in Feadora 9 (after couple of upgrades, running kernel
2.6.25.6-55.fc9.i686).

Note You need to log in before you can comment on or make changes to this bug.