Bug 221051 - System can not boot with new kernel update
System can not boot with new kernel update
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-31 09:00 EST by Clovis Sena
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-09 15:54:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clovis Sena 2006-12-31 09:00:22 EST
Hi all,

Description of problem:

I am trying to install RHEL 4 to a system with the following configuration:

- Intel motherbord D946GZ
- Intel Pentium 5 (dual core) processor
- 2GB corsair memory (DDR2)
- 02 SATA HD 160G ( Samsung HD160JJ )
- Adaptec SATA RAID Controller ( to make a RAID 1 with the two disks )

To install redhat I have to use "linux acpi=off noapic" at boot time. Inside
anaconda i've made two partition using software RAID, one for swap and other for
/. The system install was ok.

But, after first boot I had the following problems:

- only one processor was detected  ( I teste it with a Ubuntu 6.10 CD and it
detectd two)
- no network card detect ( again with Ubuntu 6.10, it detected a Intel PRO/100,
using e100 module )

- rebooting system it gives me some krash memory dump on screen and I have to
press reset buttom to reset machine.

I try to update it to maybe fix some of this errors. So I added a 3com network
card ( don't remember model now) and conected to redhat network.  There was more
than 400 packages to download. And I selected it to install kernel updates too.

After downloading and installing all thse updates, I rebooted system and try to
boot with new kernel, but it hangs just after loading the kernel.

I checked and the new kernel is also using the boot params "acpi=off noapic". I
try with and without params and had no luck.

I can still boot with old kernel, but cant detect the two processors. If i
remove the acpi=off from kernel boot option, this kernel also hangs and cannot
boot. 

I also updated the motherbord BIOS to latest one from Intel support site. Again
with no luck.

What can I do to be able to boot with this new kernel???


Version-Release number of selected component (if applicable):

RedHat enterprise 4 Update 4

kernel-smp-2.6.9-5.EL

kernel-smp-2.6.9-42.0.3.EL


How reproducible:

yes, on this system.

Steps to Reproduce:
1. install base system
2. update and install new kernel
3. try to boot with new kernel
  
Actual results:

system does not boot with new kernel version

Expected results:

complets the boot sucessfully.

Additional info:

I have to install RHEL 4 on this machine because we are going to install Oracle
database on it.
Comment 1 Clovis Sena 2006-12-31 09:07:42 EST
About Intel motherboard:

http://www.intel.com/products/motherboard/d946gzis/index.htm

About Adaptec sata raid controller:

http://www.adaptec.com/en-US/products/sata/sataraid/AAR-1210SA/

Comment 2 Clovis Sena 2006-12-31 09:23:27 EST
Using a Ubuntu 6.10, I collected cpuinfo:

cat /proc/cpuinfo

processor	: 0
vendor_id	: GenuineIntel
cpu family	: 15
model		: 4
model name	: Intel(R) Pentium(R) 5 CPU 2.66GHz
stepping	: 7
cpu MHz		: 2664.156
cache size	: 1024 KB
physical id	: 0
siblings	: 1
core id		: 255
cpu cores	: 1
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 5
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni monitor
ds_cpl tm2 cid cx16 xtpr
bogomips	: 5333.24

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 15
model		: 4
model name	: Intel(R) Pentium(R) 5 CPU 2.66GHz
stepping	: 7
cpu MHz		: 2664.156
cache size	: 1024 KB
physical id	: 1
siblings	: 1
core id		: 255
cpu cores	: 1
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 5
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni monitor
ds_cpl tm2 cid cx16 xtpr
bogomips	: 5328.24


--------------------------


Comment 3 Clovis Sena 2007-01-07 07:08:23 EST
Hi all,

I called to redhat support in Brazil and they give some boot param to load the
kernel. I tested a lot, like "acpi=noirq" and others, and in the end the boot
option that works for me was to load the kernel with "pci=nommconf".

I did a basic google to find out that this param is used to install in some
machines with Intel Core 2 Duo.  

http://www.google.com.br/search?hl=pt-BR&client=firefox&rls=org.mozilla%3Apt-BR%3Aunofficial&hs=53q&q=pci%3Dnommconf&btnG=Pesquisar&meta=

Using this very nice tip (thanks again redhat support), all my problems have gonne:

- two processors detected
- network card working ok
- reboot working as it should.

Please consider this bug can be fixed with this workaround and close it.

Note You need to log in before you can comment on or make changes to this bug.