Bug 221120 - totem-mozplugin claims to handle .mp3 files but can't
totem-mozplugin claims to handle .mp3 files but can't
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-02 01:10 EST by Christopher Beland
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-16 07:34:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2007-01-02 01:10:08 EST
I have the following RPMs installed:
totem-mozplugin-2.16.3-1.fc6
totem-2.16.3-1.fc6
firefox-1.5.0.9-1.fc6
xine-0.99.4-10.lvn6
xine-lib-1.1.3-2.fc6
xine-lib-extras-nonfree-1.1.3-3.lvn6
gstreamer-plugins-base-0.10.10-1.fc6
gstreamer-plugins-good-0.10.4-1.fc6
gstreamer-0.10.10-2.fc6
gstreamer-ffmpeg-0.10.2-0.3.20061108.lvn6
gstreamer-tools-0.10.10-2.fc6


In Firefox, about:plugins says that totem-mozplugin-2.16.3-1.fc6 is claiming to
handle files of type "audio/mpeg / MP3 audio / mp3", but in Firefox, when I
click on a link to an MP3, I get an error message from Totem:

"You do not have a decoder installed to handle this file. You might need to
install the necessary plugins."

This is the same error message I get if I try to use totem to play the file
directly.

I was puzzled why totem couldn't play mp3s when xine could, and I found that
it's using the gstreamer backend.  (There is no obvious way in the totem GUI to
switch backends.)

The upshot: The plugin package should not claim to handle file types that totem
can't actually handle.
 
As a workaround, I have uninstalled totem-mozplugin, so that I can use xmms to
play mp3s.
Comment 1 Bastien Nocera 2007-01-16 07:34:10 EST
(In reply to comment #0)
> I have the following RPMs installed:
<snip>
> The upshot: The plugin package should not claim to handle file types that totem
> can't actually handle.

The plugin has no way of knowing whether there will be an MP3 plugin to handle
the stream. I've added an item to the Totem FAQ:
http://www.gnome.org/projects/totem/#faq

> As a workaround, I have uninstalled totem-mozplugin, so that I can use xmms to
> play mp3s.

If there was a way to disable the plugins without uninstalling them, I didn't
find it. https://bugzilla.mozilla.org/show_bug.cgi?id=19118 looks like it's
still not implemented fully.

Note You need to log in before you can comment on or make changes to this bug.