Bug 221151 - Feature request: Remove all dependencies
Feature request: Remove all dependencies
Status: CLOSED DUPLICATE of bug 233249
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Depends On:
  Show dependency treegraph
Reported: 2007-01-02 09:13 EST by Karl Lattimer
Modified: 2008-04-01 07:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-01 07:01:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Karl Lattimer 2007-01-02 09:13:55 EST
Description of problem:
Sometimes I want to remove a package which is heavily depended on by installed
packages, and there is a huge tree of futher dependencies, for instance try and
uninstall GNOME on the command line you'll quickly get the idea.

It would be really nice if RPM had an rpm -e option to remove all dependent
Comment 1 Jeff Johnson 2007-01-02 11:30:12 EST
The current answer to this RFE is
    Use yum.

Comment 2 Red Hat Bugzilla 2007-08-21 01:30:39 EDT
User pnasrat@redhat.com's account has been closed
Comment 3 Panu Matilainen 2007-08-22 02:33:24 EDT
Reassigning to owner after bugzilla made a mess, sorry about the noise...
Comment 4 Panu Matilainen 2008-04-01 07:01:13 EDT

*** This bug has been marked as a duplicate of 233249 ***

Note You need to log in before you can comment on or make changes to this bug.