Bug 221157 - Evolution hangs on close on x86_64
Evolution hangs on close on x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-02 10:24 EST by Andrew Overholt
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: evolution-data-server-1.8.2-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-16 07:27:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2007-01-02 10:24:59 EST
Description of problem:
I recently started using an x86_64 box.  I have found that Evolution hangs on
close more than half the times I try to close it.  I have to `pkill evolution`
to make the window go away.

Version-Release number of selected component (if applicable):
evolution-2.8.2.1-2.fc6.x86_64

How reproducible:
~50% of the time.

Steps to Reproduce:
1. Start Evolution
2. Read mail
3. Close Evolution (with window X)
  
Actual results:
The window "INBOX (30 total, 18 unread) - Evolution" is not responding.

Forcing this application to quit will cause you to lose any unsaved changes.

Expected results:
Evolution closes normally.

Additional info:
nfs homedir, 2 IMAP accounts, lots of mail.
Comment 1 Baris Cicek 2007-01-08 10:26:37 EST
I'm running x64 and it never hangs, it might be related w/ nfs home directory.
I'm affraid this information is not enough to inspect possible crash cause. 
Comment 2 Andrew Overholt 2007-01-08 14:23:06 EST
If someone were to request information on how to track this down, I'd be more
than willing to provide it.
Comment 3 Baris Cicek 2007-01-08 15:03:32 EST
Btw, I guess culprit is imap. I tried adding an imap account, and symptoms i
experienced is send and receive never closes, even pressing Cancel does not
close window but closing window close cross works (might give some hint), and as
you stated it does not close it just make all widgets on gui disabled (might
give another hint to track down bug) and waits forever. You need to kill it to
destroy window.

I'll take a look at it, this does not happen all the time for me, but something
seems like triggers this. 
Comment 4 Ronald Kuetemeier 2007-01-10 11:48:27 EST
I got the problem on an SMP box. My guess is. It it's not thread save, since it
works fine on my Notebook. But I can make it on hang on the SMP box by just
clicking to SEND/RECEIVE mail more then once.  SMP worked fine with FC5.   
Comment 5 Matthew Barnes 2007-01-10 11:55:28 EST
See bug #208724.  It's possible these two are related.

Please try upgrading to evolution-data-server-1.8.2-2.fc6, which should be in
Fedora Updates Testing sometime today or tomorrow.
Comment 6 Ronald Kuetemeier 2007-01-10 17:53:48 EST
Tested:
evolution-data-server-1.8.2-2.fc6
from updates testing.  
Works for me, on my SMP machine. Doesn't hang anymore. 
Thanks.
Comment 7 Phil Hale 2007-01-10 20:08:40 EST
I've had the same experience on my X86_64 SMP box.
Comment 8 Phil Hale 2007-01-10 20:15:47 EST
okay, evolution-data-server-1.8.2-2.fc6 for x86_64 seems to have worked for me.
Comment 9 Matthew Barnes 2007-01-10 20:28:50 EST
Awesome!  Glad to hear it's working better.

I'll wait until this hits Fedora Updates before closing.
Comment 10 Baris Cicek 2007-01-11 06:16:21 EST
evolution-data-server-1.8.2-2.fc6 does not hang me, either. 
Comment 11 Andrew Overholt 2007-01-11 15:59:05 EST
It doesn't hang on close for me, either.
Comment 12 Baris Cicek 2007-01-16 03:42:12 EST
This bug is closed in FC6 Updates. 
Comment 13 Matthew Barnes 2007-01-16 07:27:50 EST
Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.