Bug 22116 - No kickstart install possibel for Compaq Deskpro EN PC
No kickstart install possibel for Compaq Deskpro EN PC
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-12 08:48 EST by elsen
Modified: 2014-03-16 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-14 11:40:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description elsen 2000-12-12 08:48:19 EST
I am having problems to get the Redhat 7.0 kickstart
 automatic networked installlations to work 
 on the Compaq Despro EN (PC) series.

 Apparantly the network card is not correctly supported.
 The Card Type is :

          PRO/100 EtherExpress (Intel 825xx - based)

 On CDROM type installations Redhat 7.0 will incorrectly
 choose the eepro driver for this card.
 This has to be corrected in /etc/modules.conf by
 specifying the e100(.o)  module for this card.

 
 For the kickstart mechanism however the driver has to be
 included on the boot diskette or on the drivers disk
 (drivers.img) but it is not there.
 I can modify the ramdisk on the bootdiskette or modify
 the driver disk to include a copy of the e100.o in the
 modules.cgz file and specifying an entry for this
 card in the module-info file BUT the problem is most
 probably that the version of the e100.o driver from
 a cdrom based installation is not compatible with the
 vmlinuz which is used on the boot diskette which is needed
 to get the kickstart mechanism going.

 Anyone got solutions for this ?
 Or how do I make a driver disk with a correct e100.o
 for vmlinuz boot diskette ?

 Thanks for all input.

 Marc.
Comment 1 Michael Fulbright 2000-12-12 11:44:36 EST
Assigning to an engineer.
Comment 2 Erik Troan 2000-12-12 15:23:04 EST
Are you installing from CD or from NFS? Are you getting a message, or some other
type of failure? Also, please post "lspci" results on that machine so we can use
the proper driver in the future.
Comment 3 elsen 2000-12-13 03:00:43 EST
 I am installing from diskette, with bootnet.img.
 There is no error but the fundamental problem is that the
 install procedure does not recognize the network card.
 Then a  menu is prompted to specify the correct network card.
 But the card type that is in the machine is no supported.
 It is also not supported on drivers.img.
Comment 4 elsen 2000-12-13 03:02:51 EST
The output of "lspci" is as follows :

00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and
Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82815 CGC [Chipset
Graphics Controller]  (rev 02)
00:1e.0 PCI bridge: Intel Corporation: Unknown device 244e (rev 01)
00:1f.0 ISA bridge: Intel Corporation: Unknown device 2440 (rev 01)
00:1f.1 IDE interface: Intel Corporation: Unknown device 244b (rev 01)
00:1f.4 USB Controller: Intel Corporation: Unknown device 2444 (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation: Unknown device 2445
(rev 01)
02:08.0 Ethernet controller: Intel Corporation: Unknown device 2449 (rev 01)
Comment 5 Michael Fulbright 2000-12-14 11:40:15 EST
Reassigning to kudzu component so we are sure that this card will be recognized
in the future.
Comment 6 Bill Nottingham 2000-12-14 11:42:10 EST
It's mapped in the current kudzu package to the e100 driver.
Comment 7 elsen 2000-12-15 03:17:25 EST
 Thanks for your efforts !!
 What do you mean by "current kudzu package"; can I download
 this somewhere or must I wait till RH  7.1 ?

 Regards.

 Marc.
Comment 8 Bill Nottingham 2000-12-15 08:50:59 EST
It's in the file '/usr/share/kudzu/pcitable' in the currently-in-rawhide
kudzu release. The best way to fix this for the installer is to
probably make your own updates disk.

Note You need to log in before you can comment on or make changes to this bug.