Bug 221165 - Need to fix rhncfg-* dependencies for RHEL 5 release
Summary: Need to fix rhncfg-* dependencies for RHEL 5 release
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 166615
TreeView+ depends on / blocked
 
Reported: 2007-01-02 17:22 UTC by Clifford Perry
Modified: 2013-01-10 09:05 UTC (History)
1 user (show)

Fixed In Version: rhn500h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 17:39:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Clifford Perry 2007-01-02 17:22:49 UTC
Description of problem:
Reported from mailing list: 
https://www.redhat.com/archives/rhn-satellite-beta-users/2007-January/msg00000.html


I'm not sure if rhncfg-actions is still required under RHEL5 but trying to
install it fails as up2date is an unresolved dependency

      [root@lthpjstst ~]# yum install rhncfg-actions
      Loading "installonlyn" plugin
      Loading "rhnplugin" plugin
      Setting up Install Process
      Setting up repositories
      rhel-i386-server-5-beta   100% |=========================|  951 B    00:00
      hp-rhel-i386-server-5-bet 100% |=========================|  951 B    00:00
      rhn-tools-rhel-i386-serve 100% |=========================|  951 B    00:00
      ems-rhel-i386-server-5-be 100% |=========================|  951 B    00:00
      is-rhel-i386-server-5-bet 100% |=========================|  951 B    00:00
      isg-rhel-i386-server-5-be 100% |=========================|  951 B    00:00
      Reading repository metadata in from local files
      Parsing package install arguments
      Resolving Dependencies
      --> Populating transaction set with selected packages. Please wait.
      ---> Package rhncfg-actions.noarch 0:4.1.0-2 set to be updated
      --> Running transaction check
      --> Processing Dependency: up2date for package: rhncfg-actions
      --> Finished Dependency Resolution
      Error: Missing Dependency: up2date is needed by package rhncfg-actions
      [root@lthpjstst ~]#

Other RHN packages (such as osad, rhncfg and rhncfg-client that we install on
RHEL4 systems install OK

Regards, Phil



Additional info:

Sounds like we either need to resolve the rhncfg-* spec file for what it
requires, or edit a RHEL 5 specific package to have 'up2date' as a provides
within it. Or trying to find a common package/tag for both RHEL 4 and 5. 


Cliff.

Comment 1 wes hayutin 2007-03-01 19:20:38 UTC
This is fixed.. and this bug is a dup of 221172

Comment 2 Brandon Perkins 2007-03-13 14:12:07 UTC
Closed in rhn500h Release.

Comment 3 Brandon Perkins 2007-03-13 17:39:30 UTC
Closed in rhn500h release.


Note You need to log in before you can comment on or make changes to this bug.