Bug 221202 - unexpected results from the "file" command
unexpected results from the "file" command
Status: CLOSED DUPLICATE of bug 221201
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: fileutils (Show other bugs)
4.4
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Tim Waugh
http://www.1mage.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-02 17:32 EST by Peter Anderson
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 07:02:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text file that generates spurious output from "file" command (59 bytes, text/plain)
2007-01-02 17:32 EST, Peter Anderson
no flags Details

  None (edit)
Description Peter Anderson 2007-01-02 17:32:11 EST
Description of problem:
Executing the "file" command against purely ASCII text files returns a variety 
of spurious results.  Some files return:

file1: sticky Bio-Rad .PIC Image File 12330 x 11830, 16707 images in file
or
send.to.lqm: Bio-Rad .PIC Image File 12320 x 11830, 16707 images in file
or
file3: 
svm.ics: PC icon data

The "send.to.lqm" file (attached) is only 59 characters long but the "file" 
command thinks that it is an image file 12320 x 11830 with 16707 images!?!

Files are ASCII text with carriage-return/line-feed delimeters and some contain 
a Top-of-form character (012).


Version-Release number of selected component (if applicable):
Advanced Server 4 (Nahant Update 4)
Kernel 2.6.9-42.0.3.ELsmp on an i686

The file command, when executed as "file -v" returns
file-4.10
magic file from /usr/share/file/magic


How reproducible:
execute "file" against the attached file


Steps to Reproduce:
1. execute "file" against the attached file
2.
3.
  
Actual results:
send.to.lqm: Bio-Rad .PIC Image File 12320 x 11830, 16707 images in file


Expected results:
send.to.lqm: ASCII text

Additional info:
Comment 1 Peter Anderson 2007-01-02 17:32:11 EST
Created attachment 144671 [details]
text file that generates spurious output from "file" command
Comment 2 Tim Waugh 2007-01-03 07:02:45 EST

*** This bug has been marked as a duplicate of 221201 ***

Note You need to log in before you can comment on or make changes to this bug.